aboutsummaryrefslogtreecommitdiff
path: root/modules/services/taskwarrior-sync.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2020-02-02 00:39:17 +0100
committerRobert Helgesson <robert@rycee.net>2020-02-02 01:07:28 +0100
commit45abf3d38a2b51c00c347cab6950f3734e023bba (patch)
tree414fde5d14d1d075fa65e59175660fd1fb680c43 /modules/services/taskwarrior-sync.nix
parent9799d3de2d270a9c40fcf81d600bfd71088e144d (diff)
Apply `nixfmt` on many files
Diffstat (limited to '')
-rw-r--r--modules/services/taskwarrior-sync.nix16
1 files changed, 4 insertions, 12 deletions
diff --git a/modules/services/taskwarrior-sync.nix b/modules/services/taskwarrior-sync.nix
index 4179ac8aa85..d16c0681bee 100644
--- a/modules/services/taskwarrior-sync.nix
+++ b/modules/services/taskwarrior-sync.nix
@@ -6,9 +6,7 @@ let
cfg = config.services.taskwarrior-sync;
-in
-
-{
+in {
meta.maintainers = with maintainers; [ minijackson pacien ];
options.services.taskwarrior-sync = {
@@ -32,9 +30,7 @@ in
config = mkIf cfg.enable {
systemd.user.services.taskwarrior-sync = {
- Unit = {
- Description = "Taskwarrior sync";
- };
+ Unit = { Description = "Taskwarrior sync"; };
Service = {
CPUSchedulingPolicy = "idle";
IOSchedulingClass = "idle";
@@ -43,16 +39,12 @@ in
};
systemd.user.timers.taskwarrior-sync = {
- Unit = {
- Description = "Taskwarrior periodic sync";
- };
+ Unit = { Description = "Taskwarrior periodic sync"; };
Timer = {
Unit = "taskwarrior-sync.service";
OnCalendar = cfg.frequency;
};
- Install = {
- WantedBy = [ "timers.target" ];
- };
+ Install = { WantedBy = [ "timers.target" ]; };
};
};
}