aboutsummaryrefslogtreecommitdiff
path: root/modules/services/status-notifier-watcher.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2020-06-10 23:32:44 +0200
committerRobert Helgesson <robert@rycee.net>2020-06-10 23:32:44 +0200
commit02c1f8d416d55d8bc8d4de62f65f62fef40e5e80 (patch)
treec989943bdcd774c10cd613eb8f8ece98392fb1c9 /modules/services/status-notifier-watcher.nix
parentc378c1cbcd405de8415c6be9d3fa15d50c0ed6ad (diff)
status-notifier-watcher: introduce unit start delay
Fixes #1312
Diffstat (limited to '')
-rw-r--r--modules/services/status-notifier-watcher.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/modules/services/status-notifier-watcher.nix b/modules/services/status-notifier-watcher.nix
index 3c3e54877b4..ed0537e22e1 100644
--- a/modules/services/status-notifier-watcher.nix
+++ b/modules/services/status-notifier-watcher.nix
@@ -34,7 +34,14 @@ in {
Before = [ "taffybar.service" ];
};
- Service = { ExecStart = "${cfg.package}/bin/status-notifier-watcher"; };
+ Service = {
+ ExecStart = "${cfg.package}/bin/status-notifier-watcher";
+ # Delay the unit start a bit to allow the program to get fully
+ # set up before letting dependent services start. This is
+ # brittle and a better solution using, e.g., `BusName=` might
+ # be possible.
+ ExecStartPost = "${pkgs.coreutils}/bin/sleep 1";
+ };
Install = {
WantedBy = [ "graphical-session.target" "taffybar.service" ];