aboutsummaryrefslogtreecommitdiff
path: root/modules/services/random-background.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2019-03-24 15:26:54 +0100
committerRobert Helgesson <robert@rycee.net>2019-03-24 15:29:08 +0100
commitcf5dac9563d9376abc5e81eb9f92ac533e80d531 (patch)
tree941f658412060a1d0c645f4568856db3aa77eb48 /modules/services/random-background.nix
parent2e1c825b90ce7a7bec6bcd8fc7e2f58404c415ce (diff)
random-background: minor documentation improvements
Diffstat (limited to '')
-rw-r--r--modules/services/random-background.nix18
1 files changed, 9 insertions, 9 deletions
diff --git a/modules/services/random-background.nix b/modules/services/random-background.nix
index 4f0a4c43121..2af7af0b126 100644
--- a/modules/services/random-background.nix
+++ b/modules/services/random-background.nix
@@ -17,22 +17,22 @@ in
imageDirectory = mkOption {
type = types.str;
- description =
- ''
- The directory of images from which a background should be
- chosen. Should be formatted in a way understood by
- systemd, e.g., '%h' is the home directory.
- '';
+ example = "%h/backgrounds";
+ description = ''
+ The directory of images from which a background should be
+ chosen. Should be formatted in a way understood by systemd,
+ e.g., '%h' is the home directory.
+ '';
};
interval = mkOption {
default = null;
type = types.nullOr types.str;
+ example = "1h";
description = ''
The duration between changing background image, set to null
- to only set background when logging in.
-
- Should be formatted as a duration understood by systemd.
+ to only set background when logging in. Should be formatted
+ as a duration understood by systemd.
'';
};
};