aboutsummaryrefslogtreecommitdiff
path: root/modules/services/polybar.nix
diff options
context:
space:
mode:
authorwedens <kirill.wedens@gmail.com>2018-12-31 19:01:48 +0700
committerRobert Helgesson <robert@rycee.net>2019-01-26 14:44:57 +0100
commit604fc929432597147ff8e8a1586d995c74e4e8aa (patch)
treebe6ea3b83630e30500c7a961ac3d5192eeadba32 /modules/services/polybar.nix
parent008d93928f2d53cbf70f9735efb2c08893420d2c (diff)
polybar: add /run/wrappers/bin to PATH
Without this the network module in polybar is unable to check connection as it invokes 'ping' command directly.
Diffstat (limited to '')
-rw-r--r--modules/services/polybar.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/services/polybar.nix b/modules/services/polybar.nix
index 82ae27b1661..547c7b90ff7 100644
--- a/modules/services/polybar.nix
+++ b/modules/services/polybar.nix
@@ -129,7 +129,7 @@ in
Service = {
Type = "forking";
- Environment = "PATH=${cfg.package}/bin";
+ Environment = "PATH=${cfg.package}/bin:/run/wrappers/bin";
ExecStart = ''${pkgs.writeScriptBin "polybar-start" script}/bin/polybar-start'';
};