aboutsummaryrefslogtreecommitdiff
path: root/modules/services/polybar.nix
diff options
context:
space:
mode:
authorNikita Uvarov <uv.nikita@gmail.com>2018-01-21 21:01:26 +0100
committerNikita Uvarov <uv.nikita@gmail.com>2018-01-21 21:01:26 +0100
commit1b0a5eb54a9b41ca52e26c5d23197ade7cdb63b3 (patch)
tree01cd0ca79d863424ec32106b981633bf170efd61 /modules/services/polybar.nix
parent071f7aea8238aa6c64759c58b195bb0d4f3ce9b0 (diff)
polybar: fix the case when config value is a path
Polybar treats 'include-file' property differently. In particular, its value can't be enclosed in double quotes. Fixes #185.
Diffstat (limited to '')
-rw-r--r--modules/services/polybar.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/services/polybar.nix b/modules/services/polybar.nix
index b218c6c6133..52ea7b4ec72 100644
--- a/modules/services/polybar.nix
+++ b/modules/services/polybar.nix
@@ -13,7 +13,7 @@ let
let
value' =
if isBool value then (if value then "true" else "false")
- else if isString value then "\"${value}\""
+ else if (isString value && key != "include-file") then ''"${value}"''
else toString value;
in
"${key}=${value'}";