aboutsummaryrefslogtreecommitdiff
path: root/modules/programs/starship.nix
diff options
context:
space:
mode:
authorBruno Bigras <bigras.bruno@gmail.com>2020-04-24 09:57:47 -0400
committerRobert Helgesson <robert@rycee.net>2020-05-12 20:40:34 +0200
commitcca024da2badb367b6f825d603d8f7c9bd357bf6 (patch)
treec9874f5bf715cc9959d7d14f5b9cbaa18696c657 /modules/programs/starship.nix
parent1ec45b11abdfbd92d608a6536d11e80bd648ec02 (diff)
starship: check if $TERM == "dumb" for Bash setup
This fixes an issue with Emacs tramp. PR #1191
Diffstat (limited to '')
-rw-r--r--modules/programs/starship.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/programs/starship.nix b/modules/programs/starship.nix
index cea9c49be2d..c35a8713a03 100644
--- a/modules/programs/starship.nix
+++ b/modules/programs/starship.nix
@@ -89,7 +89,7 @@ in {
mkIf (cfg.settings != { }) { source = configFile cfg.settings; };
programs.bash.initExtra = mkIf cfg.enableBashIntegration ''
- if [[ -z $INSIDE_EMACS ]]; then
+ if [[ $TERM != "dumb" && -z $INSIDE_EMACS ]]; then
eval "$(${cfg.package}/bin/starship init bash)"
fi
'';