aboutsummaryrefslogtreecommitdiff
path: root/modules/programs/neovim.nix
diff options
context:
space:
mode:
authorTobias Happ <tobias.happ@gmx.de>2019-08-10 13:55:05 +0200
committerRobert Helgesson <robert@rycee.net>2019-08-28 12:25:06 +0200
commit5d7eabb93fd70264f7e64f02fa3d4334ed01ad09 (patch)
tree635171578ff47ec74657dbe47417b81349dde751 /modules/programs/neovim.nix
parentf1146a1fef60b5455cff473a5e92acab378da236 (diff)
neovim: add finalPackage option as readOnly
Diffstat (limited to '')
-rw-r--r--modules/programs/neovim.nix23
1 files changed, 15 insertions, 8 deletions
diff --git a/modules/programs/neovim.nix b/modules/programs/neovim.nix
index d32f8f4aa19..6aaa3980ac8 100644
--- a/modules/programs/neovim.nix
+++ b/modules/programs/neovim.nix
@@ -111,6 +111,13 @@ in
description = "The package to use for the neovim binary.";
};
+ finalPackage = mkOption {
+ type = types.package;
+ visible = false;
+ readOnly = true;
+ description = "Resulting customized neovim package.";
+ };
+
configure = mkOption {
type = types.attrs;
default = {};
@@ -136,13 +143,13 @@ in
};
config = mkIf cfg.enable {
- home.packages = [
- (pkgs.wrapNeovim cfg.package {
- inherit (cfg)
- extraPython3Packages withPython3
- extraPythonPackages withPython
- withNodeJs withRuby viAlias vimAlias configure;
- })
- ];
+ home.packages = [ cfg.finalPackage ];
+
+ programs.neovim.finalPackage = pkgs.wrapNeovim cfg.package {
+ inherit (cfg)
+ extraPython3Packages withPython3
+ extraPythonPackages withPython
+ withNodeJs withRuby viAlias vimAlias configure;
+ };
};
}