aboutsummaryrefslogtreecommitdiff
path: root/modules/nix/default.nix
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2019-10-05 22:10:04 +0000
committerKatharina Fey <kookie@spacekookie.de>2019-10-05 22:10:04 +0000
commitf700d4b0404169f7e4beab940890a53de4cb79ba (patch)
tree9b0286f1dbb5515eafd178040282db60e0d26054 /modules/nix/default.nix
parentc04d9504fa2ae8f447ef05a1e7ddb3b21ed06af9 (diff)
Adding nix and base modules
Diffstat (limited to 'modules/nix/default.nix')
-rw-r--r--modules/nix/default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/modules/nix/default.nix b/modules/nix/default.nix
new file mode 100644
index 00000000000..e26bab577a7
--- /dev/null
+++ b/modules/nix/default.nix
@@ -0,0 +1,17 @@
+{ config, pkgs, ... }:
+
+{
+ nix.trustedUsers = [ "@wheel" ];
+
+ nix.nixPath = [
+ "home-manager=/run/current-system/libkookie/home-manager"
+ "nixos-config=/run/current-system/libkookie/configuration.nix"
+ "nixpkgs-overlays=/run/current-system/libkookie/overlays"
+ "nixpkgs=/run/current-system/libkookie/nixpkgs"
+ ];
+
+ system.extraSystemBuilderCmds = ''
+ ln -s ${lib.cleanSource ../..} $out/libkookie
+ '';
+
+}