aboutsummaryrefslogtreecommitdiff
path: root/modules/home-environment.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2019-04-11 01:09:27 +0200
committerRobert Helgesson <robert@rycee.net>2019-04-11 01:09:27 +0200
commitb6e1d826850fdcd79e067677ec0d5ec20fdf12b7 (patch)
tree326f79ca1681eff32d9cdf1e50768deb78a05f12 /modules/home-environment.nix
parent6cd5c8fca5ed00099060317a9fa99c1ceed72a83 (diff)
home-environment: make `home.keyboard` optional
When set to `null` then the `xsession` module will not attempt to manage the keyboard settings.
Diffstat (limited to '')
-rw-r--r--modules/home-environment.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/modules/home-environment.nix b/modules/home-environment.nix
index a25501fd7f2..c577c3072ac 100644
--- a/modules/home-environment.nix
+++ b/modules/home-environment.nix
@@ -139,9 +139,12 @@ in
};
home.keyboard = mkOption {
- type = keyboardSubModule;
+ type = types.nullOr keyboardSubModule;
default = {};
- description = "Keyboard configuration.";
+ description = ''
+ Keyboard configuration. Set to <literal>null</literal> to
+ disable Home Manager keyboard management.
+ '';
};
home.sessionVariables = mkOption {