aboutsummaryrefslogtreecommitdiff
path: root/modules/home-environment.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2018-02-08 22:54:29 +0100
committerRobert Helgesson <robert@rycee.net>2018-02-08 22:54:29 +0100
commit9ea353569a437659157230d740467778e91a2baa (patch)
treeef1158b2c21698abbf3ae5adcab629384cd515ef /modules/home-environment.nix
parent1bc59f729047886b845ffd9162d40593fad5c7f0 (diff)
Remove deprecated option `home.sessionVariableSetter`
Diffstat (limited to '')
-rw-r--r--modules/home-environment.nix31
1 files changed, 12 insertions, 19 deletions
diff --git a/modules/home-environment.nix b/modules/home-environment.nix
index 6c98343d792..164d3e9c339 100644
--- a/modules/home-environment.nix
+++ b/modules/home-environment.nix
@@ -96,6 +96,18 @@ in
{
meta.maintainers = [ maintainers.rycee ];
+ imports = [
+ (mkRemovedOptionModule [ "home" "sessionVariableSetter" ] ''
+ Session variables are now always set through the shell. This is
+ done automatically if the shell configuration is managed by Home
+ Manager. If not, then you must source the
+
+ ~/.nix-profile/etc/profile.d/hm-session-vars.sh
+
+ file yourself.
+ '')
+ ];
+
options = {
home.username = mkOption {
type = types.str;
@@ -158,25 +170,6 @@ in
'';
};
- home.sessionVariableSetter = mkOption {
- default = null;
- type = types.nullOr (types.enum [ "pam" "bash" "zsh" ]);
- example = "pam";
- description = ''
- Identifies the module that should set the session variables.
- </para><para>
- If "bash" is set then <varname>config.bash.enable</varname>
- must also be enabled.
- </para><para>
- If "pam" is set then PAM must be used to set the system
- environment. Also mind that typical environment variables
- might not be set by the time PAM starts up.
- </para><para>
- This option is DEPRECATED, the shell modules are now
- automatically setting the session variables when enabled.
- '';
- };
-
home.packages = mkOption {
type = types.listOf types.package;
default = [];