aboutsummaryrefslogtreecommitdiff
path: root/modules/home-environment.nix
diff options
context:
space:
mode:
authorRichard Yang <richard.yang@dingji.info>2017-08-22 04:43:03 +0000
committerRobert Helgesson <robert@rycee.net>2017-08-22 09:23:03 +0200
commit42f5d4404d9b938f13016cb2ba0851a9154bb4b3 (patch)
tree826ed28d0ac23a32a5e958ed94349c9664af79f1 /modules/home-environment.nix
parent5c098dc7ad2e8584b8799fd14dc79a40b86bae07 (diff)
home-environment: use relative latest profile link
Using a relative path prevents the latest version from being garbage collected.
Diffstat (limited to '')
-rw-r--r--modules/home-environment.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/home-environment.nix b/modules/home-environment.nix
index 50401e0f0fb..12317e36ec4 100644
--- a/modules/home-environment.nix
+++ b/modules/home-environment.nix
@@ -359,7 +359,7 @@ in
if [[ ! -v oldGenPath || "$oldGenPath" != "$newGenPath" ]] ; then
echo "Creating profile generation $newGenNum"
$DRY_RUN_CMD ln -Tsf $VERBOSE_ARG "$newGenPath" "$newGenProfilePath"
- $DRY_RUN_CMD ln -Tsf $VERBOSE_ARG "$newGenProfilePath" "$genProfilePath"
+ $DRY_RUN_CMD ln -Tsf $VERBOSE_ARG $(basename "$newGenProfilePath") "$genProfilePath"
$DRY_RUN_CMD ln -Tsf $VERBOSE_ARG "$newGenPath" "$newGenGcPath"
else
echo "No change so reusing latest profile generation $oldGenNum"