aboutsummaryrefslogtreecommitdiff
path: root/modules/home-environment.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2018-01-04 16:12:06 +0100
committerRobert Helgesson <robert@rycee.net>2018-01-08 21:40:32 +0100
commit18159c85b9733161ead2b8fcbfbc9fefbef9f3c7 (patch)
tree01397a4e7bcef7242e42a373554b8d32677d2d9a /modules/home-environment.nix
parentd7755de116850c4864613029abd15931471b66ea (diff)
home-environment: deprecate option `home.sessionVariableSetter`
Diffstat (limited to '')
-rw-r--r--modules/home-environment.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/modules/home-environment.nix b/modules/home-environment.nix
index 66fe430bccd..197e9dc57f3 100644
--- a/modules/home-environment.nix
+++ b/modules/home-environment.nix
@@ -159,8 +159,8 @@ in
};
home.sessionVariableSetter = mkOption {
- default = "bash";
- type = types.enum [ "pam" "bash" "zsh" ];
+ default = null;
+ type = types.nullOr (types.enum [ "pam" "bash" "zsh" ]);
example = "pam";
description = ''
Identifies the module that should set the session variables.
@@ -171,6 +171,9 @@ in
If "pam" is set then PAM must be used to set the system
environment. Also mind that typical environment variables
might not be set by the time PAM starts up.
+ </para><para>
+ This option is DEPRECATED, the shell modules are now
+ automatically setting the session variables when enabled.
'';
};