aboutsummaryrefslogtreecommitdiff
path: root/modules/default.nix
diff options
context:
space:
mode:
authorChristopher League <league@contrapunctus.net>2017-05-08 23:30:37 -0400
committerRobert Helgesson <robert@rycee.net>2017-05-13 11:41:38 +0200
commitbce262e46e573c031feb968358ff31db77b00e71 (patch)
tree260e39fb1a82f4a881eeb7c498e95bcced8f18fe /modules/default.nix
parente8fb9f50cef8e79c120f257af62b457ebfc5574c (diff)
ssh: add programs.ssh module
This module generates a `.ssh/config` file. This doesn't embed _all_ options for the ssh client, but the most common ones should be there. Example usage: ```nix programs.ssh = { enable = true; forwardAgent = true; controlMaster = "auto"; matchBlocks = [ { host = "something.blah.edu"; port = 1024; user = "cleague"; identitiesOnly = true; } { host = "host1 host2 host2.net host2.com"; port = 7422; hostname = "example.com"; serverAliveInterval = 60; } { host = "lucian"; forwardX11 = true; forwardX11Trusted = true; checkHostIP = false; }; }; }; ``` Each entry in `programs.ssh.matchBlocks` must contain a `host` field, which will be used for the block condition.
Diffstat (limited to '')
-rw-r--r--modules/default.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/modules/default.nix b/modules/default.nix
index ebec6c96fb5..e1f6b652686 100644
--- a/modules/default.nix
+++ b/modules/default.nix
@@ -20,6 +20,7 @@ let
./programs/git.nix
./programs/gnome-terminal.nix
./programs/lesspipe.nix
+ ./programs/ssh.nix
./programs/texlive.nix
./services/dunst.nix
./services/gnome-keyring.nix