aboutsummaryrefslogtreecommitdiff
path: root/modules/accounts/email.nix
diff options
context:
space:
mode:
authorNick Hu <me@nickhu.co.uk>2019-04-10 12:50:44 +0100
committerRobert Helgesson <robert@rycee.net>2019-04-12 21:26:46 +0200
commita6f0fa90f73eab34744bd1dadbc73490e86be057 (patch)
tree6b4d86bf15d7edb002cee50acc4239436c689ee5 /modules/accounts/email.nix
parent30a16e3a87d509735731706379dce9c0223fe5b9 (diff)
email: add facility for email aliases
Also update the notmuch and alot modules to include support for email aliases.
Diffstat (limited to '')
-rw-r--r--modules/accounts/email.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/modules/accounts/email.nix b/modules/accounts/email.nix
index ea9955d12a4..6bde6da0be9 100644
--- a/modules/accounts/email.nix
+++ b/modules/accounts/email.nix
@@ -207,6 +207,13 @@ let
description = "The email address of this account.";
};
+ aliases = mkOption {
+ type = types.listOf (types.strMatching ".*@.*");
+ default = [];
+ example = [ "webmaster@example.org" "admin@example.org" ];
+ description = "Alternative email addresses of this account.";
+ };
+
realName = mkOption {
type = types.str;
example = "Jane Doe";