aboutsummaryrefslogtreecommitdiff
path: root/lib/systems/default.nix
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2019-04-17 13:09:34 -0400
committerMatthew Bauer <mjbauer95@gmail.com>2019-04-19 12:03:56 -0400
commit5eea6587786edc63f9442f9c32703e62ba1729bb (patch)
tree18796c3413a1a23d78006df58fbdfdb776f39169 /lib/systems/default.nix
parent23560ea057024811dfeea8be0b7bd9b7a3d63b31 (diff)
systems: correct qemu architectures
ppc64le and ppc64 are different targets in the configure script. We can’t use the same one. TODO: canonicalize similar ones based on qemu’s configure script.
Diffstat (limited to '')
-rw-r--r--lib/systems/default.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/lib/systems/default.nix b/lib/systems/default.nix
index dd4f85c17cb..8eeab67f7f3 100644
--- a/lib/systems/default.nix
+++ b/lib/systems/default.nix
@@ -78,10 +78,9 @@ rec {
else if final.isx86 then "i386"
else {
"powerpc" = "ppc";
+ "powerpcle" = "ppc";
"powerpc64" = "ppc64";
- "powerpc64le" = "ppc64";
- "mips64" = "mips";
- "mipsel64" = "mipsel";
+ "powerpc64le" = "ppc64le";
}.${final.parsed.cpu.name} or final.parsed.cpu.name;
emulator = pkgs: let