aboutsummaryrefslogtreecommitdiff
path: root/lib/lists.nix
diff options
context:
space:
mode:
authorvolth <volth@volth.com>2019-08-13 21:52:01 +0000
committervolth <volth@volth.com>2019-08-26 21:40:19 +0000
commit35d68ef143412f579544eaac7aaa87e29f84b15e (patch)
tree7e4cc2079e73fde7e1cacdbeb17a4ea290f0a02e /lib/lists.nix
parentfe9c9f719d143632d31ac2b01f5f7cfbad161ce1 (diff)
treewide: remove redundant quotes
Diffstat (limited to 'lib/lists.nix')
-rw-r--r--lib/lists.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/lists.nix b/lib/lists.nix
index 30d87ece664..93a554f24f8 100644
--- a/lib/lists.nix
+++ b/lib/lists.nix
@@ -446,11 +446,11 @@ rec {
if length list < 2
then # finish
{ result = list; }
- else if dfsthis ? "cycle"
+ else if dfsthis ? cycle
then # there's a cycle, starting from the current vertex, return it
{ cycle = reverseList ([ dfsthis.cycle ] ++ dfsthis.visited);
inherit (dfsthis) loops; }
- else if toporest ? "cycle"
+ else if toporest ? cycle
then # there's a cycle somewhere else in the graph, return it
toporest
# Slow, but short. Can be made a bit faster with an explicit stack.