aboutsummaryrefslogtreecommitdiff
path: root/lib/customisation.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2018-07-06 16:17:54 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2018-07-09 12:33:43 -0400
commit48ccdf322d9e7a68d0caf5833511ee3e53ec7d3a (patch)
tree35427cab59ce985d7d98e8b38500a126ede73e56 /lib/customisation.nix
parent0299641c91f55a9d1687a4e1e6e9c6759187caeb (diff)
lib: Use lib.fixed-points.extends to avoid repetition
Diffstat (limited to 'lib/customisation.nix')
-rw-r--r--lib/customisation.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/customisation.nix b/lib/customisation.nix
index d942f54ee79..9017319420c 100644
--- a/lib/customisation.nix
+++ b/lib/customisation.nix
@@ -202,7 +202,7 @@ rec {
callPackage = self.newScope {};
overrideScope = g:
makeScope newScope
- (self_: let super = f self_; in super // g super self_);
+ (lib.fixed-points.extends f g);
packages = f;
};
in self;