aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/programs/getmail-accounts.nix
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2019-10-05 22:42:42 +0000
committerKatharina Fey <kookie@spacekookie.de>2019-10-05 22:44:50 +0000
commit73d865b1dae7585d0eff167271dabe77c9d0b8e6 (patch)
tree337324fab29014f3d60a8bff4979e397fb556d88 /home-manager/modules/programs/getmail-accounts.nix
parent670a2de0037acadb83433165344710dd3ac03adf (diff)
parente14d8e29606feddb29d7c27ea62dd514ef80f1e4 (diff)
Replacing nixcfg with libkookierebuild
Generally, nixcfg grew out of a dotfiles repository, that happened to also have some scripts in it. As more and more of the configuration was replaced with nix specifics (home-manager, etc...), so did nixcfg change over time (previously "stuff"). As part of this, kookiepkgs was introduced along-side nixcfg, to make it easier to add custom things to nixpkgs-based systems (NixOS). Additionally, the core system configuration was handled via private infrastructure repositories, each specific to the machine in question. The problem with this approach is a lot of redundancy when building non-userspace (read home-manager) systems and a lot of chaos with having to cherry-pick commits from different branches to work with nixpkgs trees in development. Ultimately, keeping both new package definitions, patches and configuration for the root system and userspace (home-manager) in the same repository is a _much_ better approach to solving these issues. And as such, libkookie was started: the general idea is that it includes all nix expressions that are relevant to _any_ of my computers. Under `roots`, a machine can have it's primary configuration file which is built andcopied into the nix store, so that nixpkgs can always point at the version a generation was built with, not what is on disk). Overlays contains everything that kookiepkgs used to, modules contains both system-level modules (only required on NixOS), as well as anything that is being built with home-manager. Modules are all kept in the same tree, however some require system-level access while others don't. There could be some kind of list to distinguish the two, so that userspace-only systems can still take advantage of libkookie.
Diffstat (limited to 'home-manager/modules/programs/getmail-accounts.nix')
-rw-r--r--home-manager/modules/programs/getmail-accounts.nix49
1 files changed, 49 insertions, 0 deletions
diff --git a/home-manager/modules/programs/getmail-accounts.nix b/home-manager/modules/programs/getmail-accounts.nix
new file mode 100644
index 00000000000..32e1312dc8f
--- /dev/null
+++ b/home-manager/modules/programs/getmail-accounts.nix
@@ -0,0 +1,49 @@
+{ config, lib, ... }:
+
+with lib;
+
+{
+ options.getmail = {
+ enable = mkEnableOption "the getmail mail retriever for this account";
+
+ destinationCommand = mkOption {
+ type = types.nullOr types.str;
+ default = null;
+ example = "\${pkgs.maildrop}/bin/maildrop";
+ description = ''
+ Specify a command delivering the incoming mail to your maildir.
+ '';
+ };
+
+ mailboxes = mkOption {
+ type = types.nonEmptyListOf types.str;
+ default = [];
+ example = ["INBOX" "INBOX.spam"];
+ description = ''
+ A non-empty list of mailboxes. To download all mail you can
+ use the <literal>ALL</literal> mailbox.
+ '';
+ };
+
+ delete = mkOption {
+ type = types.bool;
+ default = false;
+ description = ''
+ Enable if you want to delete read messages from the server. Most
+ users should either enable <literal>delete</literal> or disable
+ <literal>readAll</literal>.
+ '';
+ };
+
+ readAll = mkOption {
+ type = types.bool;
+ default = true;
+ description = ''
+ Enable if you want to fetch all, even the read messages from the
+ server. Most users should either enable <literal>delete</literal> or
+ disable <literal>readAll</literal>.
+ '';
+ };
+
+ };
+}