aboutsummaryrefslogtreecommitdiff
path: root/home-manager/home-manager.nix
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2020-05-20 14:23:53 -0500
committerRobert Helgesson <robert@rycee.net>2020-05-21 14:04:13 +0200
commit4d49cee1947e8b69fc7a876741dd9c0fe2650c72 (patch)
treedbfb3eff7d548dff3f128d276f0f32e5b94b4b17 /home-manager/home-manager.nix
parentdcbe0f2a31715f62a040b6602eece9c7282d191f (diff)
home-manager: allow unspecified `confAttr`
PR #1255
Diffstat (limited to '')
-rw-r--r--home-manager/home-manager.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/home-manager/home-manager.nix b/home-manager/home-manager.nix
index 7a6748942c8..04c2d28d32b 100644
--- a/home-manager/home-manager.nix
+++ b/home-manager/home-manager.nix
@@ -1,6 +1,6 @@
{ pkgs ? import <nixpkgs> {}
, confPath
-, confAttr
+, confAttr ? null
, check ? true
, newsReadIdsFile ? null
}:
@@ -11,7 +11,7 @@ let
env = import ../modules {
configuration =
- if confAttr == ""
+ if confAttr == "" || confAttr == null
then confPath
else (import confPath).${confAttr};
pkgs = pkgs;