aboutsummaryrefslogtreecommitdiff
path: root/doc/default.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2019-08-27 23:40:52 +0200
committerRobert Helgesson <robert@rycee.net>2019-08-27 23:40:52 +0200
commitdb86bd6c013d3434159885d0987e5b48d8b7b141 (patch)
tree0613c8ee8f1b20bea1a368fd76406fd82b242600 /doc/default.nix
parent13fa61744c0c8242446a349cc1e9d6279446db35 (diff)
doc: update nmd
Also perform scrubbing of `pkgs` since nmd no longer does this automatically.
Diffstat (limited to '')
-rw-r--r--doc/default.nix21
1 files changed, 18 insertions, 3 deletions
diff --git a/doc/default.nix b/doc/default.nix
index 7abe278a096..4482475c135 100644
--- a/doc/default.nix
+++ b/doc/default.nix
@@ -7,14 +7,29 @@ let
nmdSrc = pkgs.fetchFromGitLab {
owner = "rycee";
repo = "nmd";
- rev = "b57fc6657b6645086a286e62a05a1795f258daa6";
- sha256 = "1b6bdgn6d4awxi8al5hbw8vycxp4laf63l29rjrvxi2j2g69rgvc";
+ rev = "9751ca5ef6eb2ef27470010208d4c0a20e89443d";
+ sha256 = "0rbx10n8kk0bvp1nl5c8q79lz1w0p1b8103asbvwps3gmqd070hi";
};
nmd = import nmdSrc { inherit pkgs; };
+ # Make sure the used package is scrubbed to avoid actually
+ # instantiating derivations.
+ scrubbedPkgsModule = {
+ imports = [
+ {
+ _module.args = {
+ pkgs = lib.mkForce (nmd.scrubDerivations "pkgs" pkgs);
+ pkgs_i686 = lib.mkForce { };
+ };
+ }
+ ];
+ };
+
hmModulesDocs = nmd.buildModulesDocs {
- modules = import ../modules/modules.nix { inherit lib pkgs; };
+ modules =
+ import ../modules/modules.nix { inherit lib pkgs; }
+ ++ [ scrubbedPkgsModule ];
moduleRootPaths = [ ./.. ];
mkModuleUrl = path:
"https://github.com/rycee/home-manager/blob/master/${path}#blob-path";