aboutsummaryrefslogtreecommitdiff
path: root/doc/default.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2020-02-02 00:39:17 +0100
committerRobert Helgesson <robert@rycee.net>2020-02-02 01:07:28 +0100
commit45abf3d38a2b51c00c347cab6950f3734e023bba (patch)
tree414fde5d14d1d075fa65e59175660fd1fb680c43 /doc/default.nix
parent9799d3de2d270a9c40fcf81d600bfd71088e144d (diff)
Apply `nixfmt` on many files
Diffstat (limited to '')
-rw-r--r--doc/default.nix38
1 files changed, 14 insertions, 24 deletions
diff --git a/doc/default.nix b/doc/default.nix
index 97c1914a571..638027b0a78 100644
--- a/doc/default.nix
+++ b/doc/default.nix
@@ -1,8 +1,6 @@
{
- # Note, this should be "the standard library" + HM extensions.
- lib
-, pkgs
-}:
+# Note, this should be "the standard library" + HM extensions.
+lib, pkgs }:
let
@@ -19,23 +17,19 @@ let
# Make sure the used package is scrubbed to avoid actually
# instantiating derivations.
scrubbedPkgsModule = {
- imports = [
- {
- _module.args = {
- pkgs = lib.mkForce (nmd.scrubDerivations "pkgs" pkgs);
- pkgs_i686 = lib.mkForce { };
- };
- }
- ];
+ imports = [{
+ _module.args = {
+ pkgs = lib.mkForce (nmd.scrubDerivations "pkgs" pkgs);
+ pkgs_i686 = lib.mkForce { };
+ };
+ }];
};
hmModulesDocs = nmd.buildModulesDocs {
- modules =
- import ../modules/modules.nix {
- inherit lib pkgs;
- check = false;
- }
- ++ [ scrubbedPkgsModule ];
+ modules = import ../modules/modules.nix {
+ inherit lib pkgs;
+ check = false;
+ } ++ [ scrubbedPkgsModule ];
moduleRootPaths = [ ./.. ];
mkModuleUrl = path:
"https://github.com/rycee/home-manager/blob/master/${path}#blob-path";
@@ -58,9 +52,7 @@ let
'';
};
-in
-
-{
+in {
inherit nmdSrc;
options = {
@@ -71,7 +63,5 @@ in
manPages = docs.manPages;
- manual = {
- inherit (docs) html htmlOpenTool;
- };
+ manual = { inherit (docs) html htmlOpenTool; };
}