aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix24
1 files changed, 16 insertions, 8 deletions
diff --git a/shell.nix b/shell.nix
index 232c8003324c..ade2d6e97361 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,13 +1,21 @@
with import <nixpkgs> {};
stdenv.mkDerivation {
- name = "qaul";
+ name = "rstnode";
buildInputs = with pkgs; [
- rustracer rustup clangStdenv
-
- cargo-watch
-
- # Required for the docs
- mdbook graphviz
- ];
+ rustracer rustup clangStdenv stdenv
+ alsaLib pkg-config libudev steam-run
+ ] ++ (with pkgs.xlibs; [
+ libGL
+ libGLU
+ libGL_driver
+
+ libX11
+ libXcursor
+ libXi
+ libXrandr
+ libXxf86vm
+ libxcb
+ libxkbcommon
+ ]);
}