aboutsummaryrefslogtreecommitdiff
path: root/pkgs/development
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/grpc/default.nix4
-rw-r--r--pkgs/development/libraries/nanopb/default.nix4
-rw-r--r--pkgs/development/libraries/pipewire/default.nix9
-rw-r--r--pkgs/development/libraries/pipewire/pipewire-config-dir.patch30
-rw-r--r--pkgs/development/python-modules/coapthon3/default.nix17
-rw-r--r--pkgs/development/python-modules/daemonocle/default.nix42
-rw-r--r--pkgs/development/python-modules/django/3.nix4
-rw-r--r--pkgs/development/python-modules/grpcio-tools/default.nix4
-rw-r--r--pkgs/development/python-modules/influxdb-client/default.nix4
-rw-r--r--pkgs/development/python-modules/pwntools/default.nix4
-rw-r--r--pkgs/development/python-modules/py-air-control/default.nix27
-rw-r--r--pkgs/development/python-modules/trimesh/default.nix4
-rw-r--r--pkgs/development/tools/ytt/default.nix25
13 files changed, 156 insertions, 22 deletions
diff --git a/pkgs/development/libraries/grpc/default.nix b/pkgs/development/libraries/grpc/default.nix
index 98117c7ae410..c41bd5ff5aa3 100644
--- a/pkgs/development/libraries/grpc/default.nix
+++ b/pkgs/development/libraries/grpc/default.nix
@@ -3,13 +3,13 @@
}:
stdenv.mkDerivation rec {
- version = "1.33.2"; # N.B: if you change this, change pythonPackages.grpcio-tools to a matching version too
+ version = "1.34.0"; # N.B: if you change this, change pythonPackages.grpcio-tools to a matching version too
pname = "grpc";
src = fetchFromGitHub {
owner = "grpc";
repo = "grpc";
rev = "v${version}";
- sha256 = "0cc7yfa37ngrr0q9k3lm2yi4i57bfsyxwbblwc0f801k6wvgavcy";
+ sha256 = "0kipk26kg2x06mrkhb74k8vk5cn4mr89kw1f9mb04n616wkxjyxy";
fetchSubmodules = true;
};
patches = [
diff --git a/pkgs/development/libraries/nanopb/default.nix b/pkgs/development/libraries/nanopb/default.nix
index b90a8ba13aae..e71d1c6a54c9 100644
--- a/pkgs/development/libraries/nanopb/default.nix
+++ b/pkgs/development/libraries/nanopb/default.nix
@@ -9,13 +9,13 @@
stdenv.mkDerivation rec {
pname = "nanopb";
- version = "0.4.3";
+ version = "0.4.4";
src = fetchFromGitHub {
owner = pname;
repo = pname;
rev = version;
- sha256 = "sha256-32YU6LfPojvEVA2Z3DRZdGzDkSpAUgo1BueC/pl9qlY=";
+ sha256 = "0nqfi1b0szjmm1z8wd3ks64h10jblv9ip01kfggxgz6qjjfwgvq7";
};
nativeBuildInputs = [ cmake python3 python3.pkgs.wrapPython ];
diff --git a/pkgs/development/libraries/pipewire/default.nix b/pkgs/development/libraries/pipewire/default.nix
index f03f9ea88f40..d07c77f4e2eb 100644
--- a/pkgs/development/libraries/pipewire/default.nix
+++ b/pkgs/development/libraries/pipewire/default.nix
@@ -27,7 +27,7 @@
, bluezSupport ? true, bluez ? null, sbc ? null
, nativeHspSupport ? true
, ofonoSupport ? true
-, hsphfpdSupport ? false
+, hsphfpdSupport ? true
}:
let
@@ -39,7 +39,7 @@ let
in
stdenv.mkDerivation rec {
pname = "pipewire";
- version = "0.3.16";
+ version = "0.3.17";
outputs = [
"out"
@@ -56,7 +56,7 @@ stdenv.mkDerivation rec {
owner = "pipewire";
repo = "pipewire";
rev = version;
- sha256 = "0ivfx3rbg2iwjdh412zjpk9y5mzw7zh6asv4sji8lq0dzhwbz1qc";
+ sha256 = "1gzdahji23fsgjycc08h7zzv8filmzdrkyvpkljc881l4cb5l58n";
};
patches = [
@@ -66,6 +66,8 @@ stdenv.mkDerivation rec {
./installed-tests-path.patch
# Change the path of the pipewire-pulse binary in the service definition.
./pipewire-pulse-path.patch
+ # Add flag to specify configuration directory (different from the installation directory).
+ ./pipewire-config-dir.patch
];
nativeBuildInputs = [
@@ -106,6 +108,7 @@ stdenv.mkDerivation rec {
"-Dbluez5-backend-native=${mesonBool nativeHspSupport}"
"-Dbluez5-backend-ofono=${mesonBool ofonoSupport}"
"-Dbluez5-backend-hsphfpd=${mesonBool hsphfpdSupport}"
+ "-Dpipewire_config_dir=/etc/pipewire"
];
FONTCONFIG_FILE = fontsConf; # Fontconfig error: Cannot load default config file
diff --git a/pkgs/development/libraries/pipewire/pipewire-config-dir.patch b/pkgs/development/libraries/pipewire/pipewire-config-dir.patch
new file mode 100644
index 000000000000..ad1ae93684b1
--- /dev/null
+++ b/pkgs/development/libraries/pipewire/pipewire-config-dir.patch
@@ -0,0 +1,30 @@
+diff --git a/meson.build b/meson.build
+index 0073eb13..0ffc6863 100644
+--- a/meson.build
++++ b/meson.build
+@@ -34,7 +34,10 @@ pipewire_libexecdir = join_paths(prefix, get_option('libexecdir'))
+ pipewire_localedir = join_paths(prefix, get_option('localedir'))
+ pipewire_sysconfdir = join_paths(prefix, get_option('sysconfdir'))
+
+-pipewire_configdir = join_paths(pipewire_sysconfdir, 'pipewire')
++pipewire_configdir = get_option('pipewire_config_dir')
++if pipewire_configdir == ''
++ pipewire_configdir = join_paths(pipewire_sysconfdir, 'pipewire')
++endif
+ modules_install_dir = join_paths(pipewire_libdir, pipewire_name)
+
+ if host_machine.system() == 'linux'
+diff --git a/meson_options.txt b/meson_options.txt
+index 4b9e46b8..8c301459 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -56,6 +56,9 @@ option('pipewire-pulseaudio',
+ option('libpulse-path',
+ description: 'Where to install the libpulse.so library',
+ type: 'string')
++option('pipewire_config_dir',
++ type : 'string',
++ description : 'Directory for pipewire configuration (defaults to /etc/pipewire)')
+ option('spa-plugins',
+ description: 'Enable spa plugins integration',
+ type: 'boolean',
diff --git a/pkgs/development/python-modules/coapthon3/default.nix b/pkgs/development/python-modules/coapthon3/default.nix
index fbca43e4e715..6f22e8e9f296 100644
--- a/pkgs/development/python-modules/coapthon3/default.nix
+++ b/pkgs/development/python-modules/coapthon3/default.nix
@@ -1,19 +1,26 @@
-{ buildPythonPackage, cachetools, fetchPypi, lib }:
+{ buildPythonPackage, cachetools, fetchFromGitHub, isPy27, lib }:
buildPythonPackage rec {
pname = "CoAPthon3";
version = "1.0.1";
+ disabled = isPy27;
- src = fetchPypi {
- inherit pname version;
- sha256 = "1w6bwwd3qjp4b4fscagqg9wqxpdgvf4sxgzbk2d2rjqwlkyr1lnx";
+ src = fetchFromGitHub {
+ owner = "Tanganelli";
+ repo = pname;
+ rev = version;
+ sha256 = "1im35i5i72y1p9qj8ixkwq7q6ksbrmi42giqiyfgjp1ym38snl69";
};
propagatedBuildInputs = [ cachetools ];
+ # tests take in the order of 10 minutes to execute and sometimes hang forever on tear-down
+ doCheck = false;
+ pythonImportsCheck = [ "coapthon" ];
+
meta = with lib; {
+ inherit (src.meta) homepage;
description = "Python3 library to the CoAP protocol compliant with the RFC.";
- homepage = "https://github.com/Tanganelli/${pname}";
license = licenses.mit;
maintainers = with maintainers; [ urbas ];
};
diff --git a/pkgs/development/python-modules/daemonocle/default.nix b/pkgs/development/python-modules/daemonocle/default.nix
new file mode 100644
index 000000000000..ac470b83f7b2
--- /dev/null
+++ b/pkgs/development/python-modules/daemonocle/default.nix
@@ -0,0 +1,42 @@
+{ lib
+, buildPythonPackage
+, fetchFromGitHub
+, click
+, psutil
+, pytestCheckHook
+}:
+
+buildPythonPackage rec {
+ pname = "daemonocle";
+ version = "1.0.2";
+
+ src = fetchFromGitHub {
+ owner = "jnrbsn";
+ repo = "daemonocle";
+ rev = "v${version}";
+ hash = "sha256-kDCbosXTIffuCzHcReXhiW4YPbxDW3OPnTbMC/EGJrM=";
+ };
+
+ propagatedBuildInputs = [ click psutil ];
+ checkInputs = [ pytestCheckHook ];
+
+ # One third of the tests fail on the sandbox with
+ # "psutil.NoSuchProcess: no process found with pid 0".
+ doCheck = false;
+ disabledTests = [ "sudo" ];
+ pythonImportsCheck = [ "daemonocle" ];
+
+ meta = with lib; {
+ description = "A Python library for creating super fancy Unix daemons";
+ longDescription = ''
+ daemonocle is a library for creating your own Unix-style daemons
+ written in Python. It solves many problems that other daemon
+ libraries have and provides some really useful features you don't
+ often see in other daemons.
+ '';
+ homepage = "https://github.com/jnrbsn/daemonocle";
+ license = licenses.mit;
+ maintainers = [ maintainers.AluisioASG ];
+ platforms = platforms.unix;
+ };
+}
diff --git a/pkgs/development/python-modules/django/3.nix b/pkgs/development/python-modules/django/3.nix
index 84a7e8b1e3c6..c3644d6946fd 100644
--- a/pkgs/development/python-modules/django/3.nix
+++ b/pkgs/development/python-modules/django/3.nix
@@ -13,13 +13,13 @@
buildPythonPackage rec {
pname = "Django";
- version = "3.1.3";
+ version = "3.1.4";
disabled = pythonOlder "3.7";
src = fetchPypi {
inherit pname version;
- sha256 = "14b87775ffedab2ef6299b73343d1b4b41e5d4e2aa58c6581f114dbec01e3f8f";
+ sha256 = "edb10b5c45e7e9c0fb1dc00b76ec7449aca258a39ffd613dbd078c51d19c9f03";
};
patches = stdenv.lib.optional withGdal
diff --git a/pkgs/development/python-modules/grpcio-tools/default.nix b/pkgs/development/python-modules/grpcio-tools/default.nix
index a68eb704f6c3..417b9d82e2e2 100644
--- a/pkgs/development/python-modules/grpcio-tools/default.nix
+++ b/pkgs/development/python-modules/grpcio-tools/default.nix
@@ -2,11 +2,11 @@
buildPythonPackage rec {
pname = "grpcio-tools";
- version = "1.33.2";
+ version = "1.34.0";
src = fetchPypi {
inherit pname version;
- sha256 = "af40774c0275f5465f49fd92bfcd9831b19b013de4cc77b8fb38aea76fa6dce3";
+ sha256 = "db5a6f0130256d534cbe35eab37d37a448d96f4fd736e5051c6be1aee49cea1d";
};
outputs = [ "out" "dev" ];
diff --git a/pkgs/development/python-modules/influxdb-client/default.nix b/pkgs/development/python-modules/influxdb-client/default.nix
index 007ab25eb69b..141412d5bd33 100644
--- a/pkgs/development/python-modules/influxdb-client/default.nix
+++ b/pkgs/development/python-modules/influxdb-client/default.nix
@@ -14,7 +14,7 @@
buildPythonPackage rec {
pname = "influxdb-client";
- version = "1.8.0";
+ version = "1.12.0";
disabled = pythonOlder "3.6"; # requires python version >=3.6
@@ -22,7 +22,7 @@ buildPythonPackage rec {
owner = "influxdata";
repo = "influxdb-client-python";
rev = "v${version}";
- sha256 = "0gf0fjkd10yn1bb86rfapnd5diraivshn9mhzqxaxwlfah45q187";
+ sha256 = "0b4xr8nwrnikj2rnyrrcl6pym2il8iirr9f9cyg6vzfgx8l8brk9";
};
# makes test not reproducible
diff --git a/pkgs/development/python-modules/pwntools/default.nix b/pkgs/development/python-modules/pwntools/default.nix
index 11c3f1dd8eb0..a6f43ae5b1f8 100644
--- a/pkgs/development/python-modules/pwntools/default.nix
+++ b/pkgs/development/python-modules/pwntools/default.nix
@@ -24,12 +24,12 @@
}:
buildPythonPackage rec {
- version = "4.3.0";
+ version = "4.3.1";
pname = "pwntools";
src = fetchPypi {
inherit pname version;
- sha256 = "007xbm4pg28bhv7j7m8gmzsmr9x7pdb7rkm5y80mca8kb7gw59xv";
+ sha256 = "12ja913kz8wl4afrmpzxh9fx6j7rcwc2vqzkvfr1fxn42gkqhqf4";
};
# Upstream has set an upper bound on unicorn because of https://github.com/Gallopsled/pwntools/issues/1538,
diff --git a/pkgs/development/python-modules/py-air-control/default.nix b/pkgs/development/python-modules/py-air-control/default.nix
new file mode 100644
index 000000000000..77b61123d9e0
--- /dev/null
+++ b/pkgs/development/python-modules/py-air-control/default.nix
@@ -0,0 +1,27 @@
+{ buildPythonPackage, coapthon3, fetchFromGitHub, isPy27, lib, pycryptodomex }:
+
+buildPythonPackage rec {
+ pname = "py-air-control";
+ version = "2.1.0";
+ disabled = isPy27;
+
+ src = fetchFromGitHub {
+ owner = "rgerganov";
+ repo = pname;
+ rev = "v${version}";
+ sha256 = "0mkggl5hwmj90djxbbz4svim6iv7xl8k324cb4rlc75p5rgcdwmh";
+ };
+
+ propagatedBuildInputs = [ pycryptodomex coapthon3 ];
+
+ # tests sometimes hang forever on tear-down
+ doCheck = false;
+ pythonImportsCheck = [ "pyairctrl" ];
+
+ meta = with lib; {
+ inherit (src.meta) homepage;
+ description = "Command Line App for Controlling Philips Air Purifiers.";
+ license = licenses.mit;
+ maintainers = with maintainers; [ urbas ];
+ };
+}
diff --git a/pkgs/development/python-modules/trimesh/default.nix b/pkgs/development/python-modules/trimesh/default.nix
index 2829c4e1901d..91c1ec38e9a6 100644
--- a/pkgs/development/python-modules/trimesh/default.nix
+++ b/pkgs/development/python-modules/trimesh/default.nix
@@ -2,11 +2,11 @@
buildPythonPackage rec {
pname = "trimesh";
- version = "3.8.14";
+ version = "3.8.15";
src = fetchPypi {
inherit pname version;
- sha256 = "dba3d9fa1d9488053fc7504c141fbb2258cf5f37377a3824b20bd0a93f7240a0";
+ sha256 = "3ab9c15e53916fd68d0c0ca9b46d95693d3238f164ffcf528a974c6e15cd353e";
};
propagatedBuildInputs = [ numpy ];
diff --git a/pkgs/development/tools/ytt/default.nix b/pkgs/development/tools/ytt/default.nix
new file mode 100644
index 000000000000..05410bbaec52
--- /dev/null
+++ b/pkgs/development/tools/ytt/default.nix
@@ -0,0 +1,25 @@
+{ lib, buildGoModule, fetchFromGitHub }:
+buildGoModule rec {
+ pname = "ytt";
+ version = "0.30.0";
+
+ src = fetchFromGitHub {
+ owner = "vmware-tanzu";
+ repo = "carvel-ytt";
+ rev = "v${version}";
+ sha256 = "0v9wp15aj4r7wif8i897zwj3c6bg41b95kk7vi3a3bzin814qn6l";
+ };
+
+ goPackagePath = "github.com/vmware-tanzu/carvel-ytt";
+
+ vendorSha256 = null;
+
+ subPackages = [ "cmd/ytt" ];
+
+ meta = with lib; {
+ description = "YAML templating tool that allows configuration of complex software via reusable templates with user-provided values";
+ homepage = "https://get-ytt.io";
+ license = licenses.asl20;
+ maintainers = with maintainers; [ brodes ];
+ };
+}