aboutsummaryrefslogtreecommitdiff
path: root/pkgs/applications
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/gphoto2/default.nix37
-rw-r--r--pkgs/applications/networking/browsers/chromium/common.nix21
-rw-r--r--pkgs/applications/networking/browsers/chromium/default.nix5
-rw-r--r--pkgs/applications/version-management/git-and-tools/git/default.nix11
4 files changed, 44 insertions, 30 deletions
diff --git a/pkgs/applications/misc/gphoto2/default.nix b/pkgs/applications/misc/gphoto2/default.nix
index cdfbe3f6dc1f..7bda292a4cba 100644
--- a/pkgs/applications/misc/gphoto2/default.nix
+++ b/pkgs/applications/misc/gphoto2/default.nix
@@ -1,17 +1,38 @@
-{ stdenv, fetchurl, pkgconfig, libgphoto2, libexif, popt, gettext
-, libjpeg, readline, libtool
+{ stdenv, fetchFromGitHub, autoreconfHook, pkgconfig
+, gettext
+, libexif
+, libgphoto2
+, libjpeg
+, libtool
+, popt
+, readline
}:
stdenv.mkDerivation rec {
- name = "gphoto2-2.5.26";
+ pname = "gphoto2";
+ version = "2.5.26";
- src = fetchurl {
- url = "mirror://sourceforge/gphoto/${name}.tar.bz2";
- sha256 = "0bxbcn31xalsvjp8fra324hf2105y3ps7zlyfz11v71j0lxj2lvn";
+ src = fetchFromGitHub {
+ owner = "gphoto";
+ repo = "gphoto2";
+ rev = "v${version}";
+ sha256 = "1w01j3qvjl2nlfs38rnsmjvn3r0r2xf7prxz1i6yarbpj3fzwqqc";
};
- nativeBuildInputs = [ pkgconfig gettext libtool ];
- buildInputs = [ libgphoto2 libexif popt libjpeg readline ];
+ nativeBuildInputs = [
+ autoreconfHook
+ pkgconfig
+ gettext
+ libtool
+ ];
+
+ buildInputs = [
+ libexif
+ libgphoto2
+ libjpeg
+ popt
+ readline
+ ];
meta = with stdenv.lib; {
description = "A ready to use set of digital camera software applications";
diff --git a/pkgs/applications/networking/browsers/chromium/common.nix b/pkgs/applications/networking/browsers/chromium/common.nix
index f167ab105d34..0c16d0c9ec60 100644
--- a/pkgs/applications/networking/browsers/chromium/common.nix
+++ b/pkgs/applications/networking/browsers/chromium/common.nix
@@ -18,20 +18,14 @@
, ffmpeg, libxslt, libxml2, at-spi2-core
, jre8
, pipewire_0_2
+, libva
# optional dependencies
, libgcrypt ? null # gnomeSupport || cupsSupport
-, libva ? null # useVaapi
, libdrm ? null, wayland ? null, mesa ? null, libxkbcommon ? null # useOzone
# package customization
-, useOzone ? false
-, useVaapi ? !(useOzone || stdenv.isAarch64) # Built if supported, but disabled in the wrapper
-# VA-API TODOs:
-# - Ozone: M81 fails to build due to "ozone_platform_gbm = false"
-# - Possible solutions: Write a patch to fix the build (wrong gn dependencies)
-# or build with minigbm
-# - AArch64: Causes serious regressions (https://github.com/NixOS/nixpkgs/pull/85253#issuecomment-614405879)
+, useOzone ? true
, gnomeSupport ? false, gnome ? null
, gnomeKeyringSupport ? false, libgnome-keyring3 ? null
, proprietaryCodecs ? true
@@ -141,8 +135,8 @@ let
pciutils protobuf speechd libXdamage at-spi2-core
jre
pipewire_0_2
- ] ++ optional useVaapi libva
- ++ optional gnomeKeyringSupport libgnome-keyring3
+ libva
+ ] ++ optional gnomeKeyringSupport libgnome-keyring3
++ optionals gnomeSupport [ gnome.GConf libgcrypt ]
++ optionals cupsSupport [ libgcrypt cups ]
++ optional pulseSupport libpulseaudio
@@ -220,9 +214,8 @@ let
custom_toolchain = "//build/toolchain/linux/unbundle:default";
host_toolchain = "//build/toolchain/linux/unbundle:default";
is_official_build = true;
- is_debug = false;
- proprietary_codecs = false;
+ use_vaapi = !stdenv.isAarch64; # TODO: Remove once M88 is released
use_sysroot = false;
use_gnome_keyring = gnomeKeyringSupport;
use_gio = gnomeSupport;
@@ -238,7 +231,6 @@ let
rtc_use_pipewire = true;
treat_warnings_as_errors = false;
- is_clang = stdenv.cc.isClang;
clang_use_chrome_plugins = false;
blink_symbol_level = 0;
symbol_level = 0;
@@ -256,14 +248,11 @@ let
proprietary_codecs = true;
enable_hangout_services_extension = true;
ffmpeg_branding = "Chrome";
- } // optionalAttrs useVaapi {
- use_vaapi = true;
} // optionalAttrs pulseSupport {
use_pulseaudio = true;
link_pulseaudio = true;
} // optionalAttrs useOzone {
use_ozone = true;
- ozone_platform_gbm = false;
use_xkbcommon = true;
use_glib = true;
use_gtk = true;
diff --git a/pkgs/applications/networking/browsers/chromium/default.nix b/pkgs/applications/networking/browsers/chromium/default.nix
index 845a4ac3b61b..e35e4d945dde 100644
--- a/pkgs/applications/networking/browsers/chromium/default.nix
+++ b/pkgs/applications/networking/browsers/chromium/default.nix
@@ -15,7 +15,6 @@
, enablePepperFlash ? false
, enableWideVine ? false
, enableVaapi ? false # Disabled by default due to unofficial support
-, useOzone ? true
, cupsSupport ? true
, pulseSupport ? config.pulseaudio or stdenv.isLinux
, commandLineArgs ? ""
@@ -34,15 +33,13 @@ let
mkChromiumDerivation = callPackage ./common.nix ({
inherit channel gnome gnomeSupport gnomeKeyringSupport proprietaryCodecs
- cupsSupport pulseSupport useOzone;
+ cupsSupport pulseSupport;
gnChromium = gn.overrideAttrs (oldAttrs: {
inherit (upstream-info.deps.gn) version;
src = fetchgit {
inherit (upstream-info.deps.gn) url rev sha256;
};
});
- # TODO: Cleanup useOzone and useVaapi in common.nix:
- useVaapi = !stdenv.isAarch64; # TODO: Might be best to not set use_vaapi anymore (default is fine)
});
browser = callPackage ./browser.nix { inherit channel enableWideVine; };
diff --git a/pkgs/applications/version-management/git-and-tools/git/default.nix b/pkgs/applications/version-management/git-and-tools/git/default.nix
index b7e4f3e6c483..57f6703762d1 100644
--- a/pkgs/applications/version-management/git-and-tools/git/default.nix
+++ b/pkgs/applications/version-management/git-and-tools/git/default.nix
@@ -1,4 +1,5 @@
{ fetchurl, stdenv, buildPackages
+, fetchpatch
, curl, openssl, zlib, expat, perlPackages, python3, gettext, cpio
, gnugrep, gnused, gawk, coreutils # needed at runtime by git-filter-branch etc
, openssh, pcre2
@@ -51,6 +52,12 @@ stdenv.mkDerivation {
./ssh-path.patch
./git-send-email-honor-PATH.patch
./installCheck-path.patch
+ (fetchpatch {
+ # https://github.com/git/git/pull/925
+ name = "make-manual-reproducible.patch";
+ url = "https://github.com/git/git/commit/7a68e9e0b8eda91eb576bbbc5ed66298f3ab761c.patch";
+ sha256 = "02naws82pd3vvwrrgqn91kid8qkjihyjaz1ahgjz8qlmnn2avf5n";
+ })
];
postPatch = ''
@@ -229,8 +236,8 @@ stdenv.mkDerivation {
notSupported $out/libexec/git-core/git-send-email
'')
- + stdenv.lib.optionalString withManual ''# Install man pages and Info manual
- make -j $NIX_BUILD_CORES -l $NIX_BUILD_CORES USE_ASCIIDOCTOR=1 PERL_PATH="${buildPackages.perl}/bin/perl" cmd-list.made install install-html install-info \
+ + stdenv.lib.optionalString withManual ''# Install man pages
+ make -j $NIX_BUILD_CORES -l $NIX_BUILD_CORES USE_ASCIIDOCTOR=1 PERL_PATH="${buildPackages.perl}/bin/perl" cmd-list.made install install-html \
-C Documentation ''
+ (if guiSupport then ''