aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/services/system/dbus.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/system/dbus.nix')
-rw-r--r--nixos/modules/services/system/dbus.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/nixos/modules/services/system/dbus.nix b/nixos/modules/services/system/dbus.nix
index f8d909a4a3cc..d4cacb85694b 100644
--- a/nixos/modules/services/system/dbus.nix
+++ b/nixos/modules/services/system/dbus.nix
@@ -11,6 +11,7 @@ let
homeDir = "/run/dbus";
configDir = pkgs.makeDBusConf {
+ inherit (cfg) apparmor;
suidHelper = "${config.security.wrapperDir}/dbus-daemon-launch-helper";
serviceDirectories = cfg.packages;
};
@@ -51,6 +52,20 @@ in
'';
};
+ apparmor = mkOption {
+ type = types.enum [ "enabled" "disabled" "required" ];
+ description = ''
+ AppArmor mode for dbus.
+
+ <literal>enabled</literal> enables mediation when it's
+ supported in the kernel, <literal>disabled</literal>
+ always disables AppArmor even with kernel support, and
+ <literal>required</literal> fails when AppArmor was not found
+ in the kernel.
+ '';
+ default = "disabled";
+ };
+
socketActivated = mkOption {
type = types.nullOr types.bool;
default = null;