aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/services/networking/tailscale.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/networking/tailscale.nix')
-rw-r--r--nixos/modules/services/networking/tailscale.nix11
1 files changed, 9 insertions, 2 deletions
diff --git a/nixos/modules/services/networking/tailscale.nix b/nixos/modules/services/networking/tailscale.nix
index d6684d69e615..1a1474595beb 100644
--- a/nixos/modules/services/networking/tailscale.nix
+++ b/nixos/modules/services/networking/tailscale.nix
@@ -14,11 +14,18 @@ in {
default = 41641;
description = "The port to listen on for tunnel traffic (0=autoselect).";
};
+
+ package = mkOption {
+ type = types.package;
+ default = pkgs.tailscale;
+ defaultText = "pkgs.tailscale";
+ description = "The package to use for tailscale";
+ };
};
config = mkIf cfg.enable {
- environment.systemPackages = [ pkgs.tailscale ]; # for the CLI
- systemd.packages = [ pkgs.tailscale ];
+ environment.systemPackages = [ cfg.package ]; # for the CLI
+ systemd.packages = [ cfg.package ];
systemd.services.tailscaled = {
wantedBy = [ "multi-user.target" ];
serviceConfig.Environment = "PORT=${toString cfg.port}";