aboutsummaryrefslogtreecommitdiff
path: root/lib/trivial.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/trivial.nix')
-rw-r--r--lib/trivial.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/lib/trivial.nix b/lib/trivial.nix
index e702b8cdcc9f..bba284548d98 100644
--- a/lib/trivial.nix
+++ b/lib/trivial.nix
@@ -188,6 +188,26 @@ rec {
warn = msg: builtins.trace "WARNING: ${msg}";
info = msg: builtins.trace "INFO: ${msg}";
+ /* Print a trace message if pred is false.
+ Intended to be used to augment asserts with helpful error messages.
+
+ Example:
+ assertMsg false "nope"
+ => false
+ stderr> trace: nope
+
+ assert (assertMsg ("foo" == "bar") "foo is not bar, silly"); ""
+ stderr> trace: foo is not bar, silly
+ stderr> assert failed at …
+
+ Type:
+ assertMsg :: Bool -> String -> Bool
+ */
+ assertMsg = pred: msg:
+ if pred
+ then true
+ else builtins.trace msg false;
+
## Function annotations