aboutsummaryrefslogtreecommitdiff
path: root/lib/strings.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/strings.nix')
-rw-r--r--lib/strings.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/strings.nix b/lib/strings.nix
index 2fd8479290d2..5010d9159cb8 100644
--- a/lib/strings.nix
+++ b/lib/strings.nix
@@ -593,9 +593,9 @@ rec {
standard GNU Autoconf scripts.
Example:
- with_Feature true "shared" "foo"
+ withFeatureAs true "shared" "foo"
=> "--with-shared=foo"
- with_Feature false "shared" (throw "ignored")
+ withFeatureAs false "shared" (throw "ignored")
=> "--without-shared"
*/
withFeatureAs = with_: feat: value: withFeature with_ feat + optionalString with_ "=${value}";
@@ -674,7 +674,7 @@ rec {
else
false;
- /* Parse a string string as an int.
+ /* Parse a string as an int.
Type: string -> int