aboutsummaryrefslogtreecommitdiff
path: root/lib/customisation.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/customisation.nix')
-rw-r--r--lib/customisation.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/customisation.nix b/lib/customisation.nix
index 9017319420c8..d942f54ee798 100644
--- a/lib/customisation.nix
+++ b/lib/customisation.nix
@@ -202,7 +202,7 @@ rec {
callPackage = self.newScope {};
overrideScope = g:
makeScope newScope
- (lib.fixed-points.extends f g);
+ (self_: let super = f self_; in super // g super self_);
packages = f;
};
in self;