aboutsummaryrefslogtreecommitdiff
path: root/infra/website/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'infra/website/default.nix')
-rw-r--r--infra/website/default.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/infra/website/default.nix b/infra/website/default.nix
index dd9bb7c1daa6..c33e034a559d 100644
--- a/infra/website/default.nix
+++ b/infra/website/default.nix
@@ -1,13 +1,18 @@
with import <nixpkgs> {};
+let
+ pelican = (pkgs.python3Packages.pelican.overrideAttrs ({ ... }: {
+ doInstallCheck = false;
+ }));
+in
stdenv.mkDerivation {
name = "website";
src = ./.;
buildInputs = with pkgs; [
python3
- ] ++ (with pkgs.python3Packages; [
pelican
+ ] ++ (with pkgs.python3Packages; [
markdown
webassets
]);