aboutsummaryrefslogtreecommitdiff
path: root/infra/libkookie/modules/workstation/ui/i3/x.nix
diff options
context:
space:
mode:
Diffstat (limited to 'infra/libkookie/modules/workstation/ui/i3/x.nix')
-rw-r--r--infra/libkookie/modules/workstation/ui/i3/x.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/infra/libkookie/modules/workstation/ui/i3/x.nix b/infra/libkookie/modules/workstation/ui/i3/x.nix
new file mode 100644
index 000000000000..1313c138c8f1
--- /dev/null
+++ b/infra/libkookie/modules/workstation/ui/i3/x.nix
@@ -0,0 +1,27 @@
+{ lib, config, ... }:
+
+let cfg = config.libkookie.ui.i3;
+in
+{
+ enable = true;
+ desktopManager = {
+ xfce = {
+ enable = true;
+ noDesktop = true;
+ enableXfwm = false;
+ };
+ };
+
+ displayManager.defaultSession = lib.mkIf cfg.defaultSession "xfce+i3";
+
+ windowManager.i3.enable = true;
+
+ useGlamor = true;
+
+ inherit (cfg) videoDrivers;
+
+ deviceSection = ''
+ Option "DRI" "2"
+ Option "TearFree" "true"
+ '';
+}