aboutsummaryrefslogtreecommitdiff
path: root/infra/libkookie/modules/workstation/ui/i3/core/setup.nix
diff options
context:
space:
mode:
Diffstat (limited to 'infra/libkookie/modules/workstation/ui/i3/core/setup.nix')
-rw-r--r--infra/libkookie/modules/workstation/ui/i3/core/setup.nix73
1 files changed, 33 insertions, 40 deletions
diff --git a/infra/libkookie/modules/workstation/ui/i3/core/setup.nix b/infra/libkookie/modules/workstation/ui/i3/core/setup.nix
index 76b4b61ac696..1839869cb260 100644
--- a/infra/libkookie/modules/workstation/ui/i3/core/setup.nix
+++ b/infra/libkookie/modules/workstation/ui/i3/core/setup.nix
@@ -23,48 +23,41 @@ in
extraConfig = with pkgs;
let
- fehCmd = "${feh}/bin/feh --bg-fill ${cfg.wallpaper}";
- picomCmd = "";
- nmCmd = if cfg.networkmanager
- then "exec_always --no-startup-id ${networkmanagerapplet}/bin/nm-applet"
- else "";
+ fehCommand = "${feh}/bin/feh --bg-fill ${cfg.wallpaper}";
in
- ''
- # Setup compositor // TODO: gate this on the hm-module
- exec_always --no-startup-id "${coreutils}/bin/pkill picom; ${picom}/bin/picom --config ~/.config/i3/picom.conf"
-
- # Make CAPSLOCK into ESC because it's 2018
- #
- # Okay actually this is slightly more complicated than that. I'm binding
- # CAPSLOCK to HYPER, so that I can use it as a modifier in emacs, but then
- # using xcape(1) to also make short CAPSLOCK presses into ESCAPE.
-
- exec_always --no-startup-id "${xorg.xmodmap}/bin/setxkbmap -layout us -variant altgr-intl -option caps:hyper"
- exec ${xcape}/bin/xcape -e "#66=Escape" -t 150
-
- # Set the desired wallpaper
- exec_always --no-startup-id ${fehCmd}
-
- # Start nm-applet if networkmanager is enabled
- ${nmCmd}
-
- bar {
- status_command ${i3status}/bin/i3status -c ~/.config/i3/i3status.conf
- position bottom
- bindsym button4 nop
- bindsym button5 nop
- colors {
- background #0F0F0F
- statusline #D5D5D5
- }
+ ''
+ # Setup compositor
+ exec_always --no-startup-id "${coreutils}/bin/pkill picom; ${picom}/bin/picom --config ~/.config/i3/picom.conf"
+
+ # Make CAPSLOCK into ESC because it's 2018
+ #
+ # Okay actually this is slightly more complicated than that. I'm binding
+ # CAPSLOCK to HYPER, so that I can use it as a modifier in emacs, but then
+ # using xcape(1) to also make short CAPSLOCK presses into ESCAPE.
+
+ exec_always --no-startup-id "${xorg.xmodmap}/bin/setxkbmap -layout us -variant altgr-intl -option caps:hyper"
+ exec ${xcape}/bin/xcape -e "#66=Escape" -t 150
+
+ # Always set a wallpaper
+ exec_always --no-startup-id ${fehCommand}
+
+ bar {
+ status_command ${i3status}/bin/i3status -c ~/.config/i3/i3status.conf
+ position bottom
+ bindsym button4 nop
+ bindsym button5 nop
+ colors {
+ background #0F0F0F
+ statusline #D5D5D5
}
-
- focus_follows_mouse no
-
- # Layout and design settings that should _really_ be in the module
- default_border pixel 3
- client.focused #4c7899 #285577 #ffffff #F73E5F #666666
- '';
+ }
+
+ focus_follows_mouse no
+
+ # Layout and design settings that should _really_ be in the module
+ default_border pixel 3
+ client.focused #4c7899 #285577 #ffffff #F73E5F #666666
+ '';
};
xdg.configFile."i3/picom.conf" = (import ./picom.nix args);