aboutsummaryrefslogtreecommitdiff
path: root/infra/libkookie/modules/workstation/ui/i3/core/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'infra/libkookie/modules/workstation/ui/i3/core/config.nix')
-rw-r--r--infra/libkookie/modules/workstation/ui/i3/core/config.nix27
1 files changed, 26 insertions, 1 deletions
diff --git a/infra/libkookie/modules/workstation/ui/i3/core/config.nix b/infra/libkookie/modules/workstation/ui/i3/core/config.nix
index e0fd5938ef2f..6cb379165406 100644
--- a/infra/libkookie/modules/workstation/ui/i3/core/config.nix
+++ b/infra/libkookie/modules/workstation/ui/i3/core/config.nix
@@ -16,6 +16,31 @@ rec {
inherit (cfg) fonts;
- keybindings = (import ./keys.nix { inherit modifier;
+ keybindings = (import ./keys.nix { inherit cfg modifier;
pkgs = xtraPkgs; });
+
+ modes = {
+
+ # Explicitly handle the resize mode
+ resize = {
+ "h" = "resize shrink width 5 px or 5 ppt";
+ "j" = "resize grow height 5 px or 5 ppt";
+ "k" = "resize shrink height 5 px or 5 ppt";
+ "l" = "resize grow width 5 px or 5 ppt";
+
+ # same bindings, but for the arrow keys
+ "Left" = "resize shrink width 5 px or 5 ppt";
+ "Down" = "resize grow height 5 px or 5 ppt";
+ "Up" = "resize shrink height 5 px or 5 ppt";
+ "Right" = "resize grow width 5 px or 5 ppt";
+
+ # back to normal: Enter or Escape or $mod+r
+ "Return" = "mode \"default\"";
+ "Escape" = "mode \"default\"";
+ "${modifier}+r" = "mode \"default\"";
+ } ;
+ };
+
+ # The `bars` module does weird stuff so we init it ourselves
+ bars = [];
}