aboutsummaryrefslogtreecommitdiff
path: root/infra/libkookie/modules/workstation/ui/i3/core.nix
diff options
context:
space:
mode:
Diffstat (limited to 'infra/libkookie/modules/workstation/ui/i3/core.nix')
-rw-r--r--infra/libkookie/modules/workstation/ui/i3/core.nix27
1 files changed, 22 insertions, 5 deletions
diff --git a/infra/libkookie/modules/workstation/ui/i3/core.nix b/infra/libkookie/modules/workstation/ui/i3/core.nix
index 5969718f3d1b..603de1e6c39e 100644
--- a/infra/libkookie/modules/workstation/ui/i3/core.nix
+++ b/infra/libkookie/modules/workstation/ui/i3/core.nix
@@ -1,9 +1,26 @@
-{ pkgs, ... }:
+{ lib, config, pkgs, home-manager, ... } @ args:
-let
- wallpaper = config.libkookie.ui.i3.wallpaper;
+let baseCfg = (import ./config.nix args);
in
{
- xsession.windowManager.i3 = import ./config.nix { inherit pkgs wallpaper; };
-{
+ # FIXME: introduce a mechanism to allow pre-user overrides! this
+ # needs to be supported by the module _or_ we have some very generic
+ # mechanism in libkookie.harness to handle this. But as it stands
+ # right now, all users will have the same i3 config.
+ home-manager.users = with lib;
+ (listToAttrs (map (user: nameValuePair "${user}" ({ ... }:
+ { imports = [ ./setup.nix ]; })) config.libkookie.activeUsers));
+
+ # FIXME: add 32bit driver support only if steam support is enabled
+ hardware.opengl = {
+ enable = true;
+ driSupport = true;
+ extraPackages = with pkgs; [
+ libGL xorg.xf86videoati xorg.xf86inputlibinput
+ ];
+ driSupport32Bit = true;
+ };
+
+ services.xserver = (import ./x.nix args);
+}