aboutsummaryrefslogtreecommitdiff
path: root/infra/libkookie/modules/workstation/ui/i3/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'infra/libkookie/modules/workstation/ui/i3/config.nix')
-rw-r--r--infra/libkookie/modules/workstation/ui/i3/config.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/infra/libkookie/modules/workstation/ui/i3/config.nix b/infra/libkookie/modules/workstation/ui/i3/config.nix
new file mode 100644
index 000000000000..7d6e7e8932b1
--- /dev/null
+++ b/infra/libkookie/modules/workstation/ui/i3/config.nix
@@ -0,0 +1,22 @@
+
+/** A base configuration template for i3
+ *
+ * This set of configuration values is meant to work on _all_
+ * systems. No device specifics are included. This set must be
+ * merged with device specific options before being applied
+ */
+{ config, pkgs, ... } @ args:
+
+let
+ cfg = config.libkookie.ui.i3;
+ xtraPkgs = pkgs // (import ./tools args);
+in
+rec {
+ # This is not configurable by design
+ modifier = "Mod4";
+
+ inherit (cfg) fonts;
+
+ keybindings = (import ./keys.nix { inherit modifier;
+ pkgs = xtraPkgs; });
+}