aboutsummaryrefslogtreecommitdiff
path: root/infra/libkookie/modules/harness/lib.nix
diff options
context:
space:
mode:
Diffstat (limited to 'infra/libkookie/modules/harness/lib.nix')
-rw-r--r--infra/libkookie/modules/harness/lib.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/infra/libkookie/modules/harness/lib.nix b/infra/libkookie/modules/harness/lib.nix
index d4da08a8de48..842f02adfd36 100644
--- a/infra/libkookie/modules/harness/lib.nix
+++ b/infra/libkookie/modules/harness/lib.nix
@@ -15,4 +15,10 @@ in
# Load a simple path with the standard set of arguments
load = path: (import path) args;
+
+ # Patch an attribute set with access to the original set
+ #
+ # This function wraps around lib.recursiveUpdate to make it slighly
+ # less cumbersome to work with in one-liners.
+ patchAttrs = attrs: f: (lib.recursiveUpdate attrs (f attrs));
}