aboutsummaryrefslogtreecommitdiff
path: root/infra/libkookie/configuration/workstation/yubikey/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'infra/libkookie/configuration/workstation/yubikey/default.nix')
-rw-r--r--infra/libkookie/configuration/workstation/yubikey/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/infra/libkookie/configuration/workstation/yubikey/default.nix b/infra/libkookie/configuration/workstation/yubikey/default.nix
new file mode 100644
index 000000000000..f139e3395e06
--- /dev/null
+++ b/infra/libkookie/configuration/workstation/yubikey/default.nix
@@ -0,0 +1,15 @@
+{ config, pkgs, ... }:
+
+with pkgs;
+{
+ services.udev.packages = [ yubikey-personalization ];
+
+ # Sometimes this is needed, so we keep it here
+ # services.pcscd.enable = true;
+
+ # FIXME: Can I remove these?
+ # Previously these rules were required to make
+ # Yubikey support work on `uwu`, but maybe this
+ # is redundant with special udev rules?
+ environment.systemPackages = [ yubikey-manager yubikey-personalization ];
+}