aboutsummaryrefslogtreecommitdiff
path: root/infra/libkookie/configuration/workstation/kitty/uwu.nix
diff options
context:
space:
mode:
Diffstat (limited to 'infra/libkookie/configuration/workstation/kitty/uwu.nix')
-rw-r--r--infra/libkookie/configuration/workstation/kitty/uwu.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/infra/libkookie/configuration/workstation/kitty/uwu.nix b/infra/libkookie/configuration/workstation/kitty/uwu.nix
new file mode 100644
index 000000000000..25204a6f398c
--- /dev/null
+++ b/infra/libkookie/configuration/workstation/kitty/uwu.nix
@@ -0,0 +1,21 @@
+/**
+ * The main configuration for kitty used on _all_ systems.
+ *
+ * The module is designed to use the default values I would like to
+ * use on my systems, however this will not stay this way, seeing as
+ * I plan on replacing it with the home-manager module in the future
+ * which will be tailored less to my use-case :)
+ */
+
+{ config, home-manager, ... }:
+
+{
+ # Load the home-manager kitty module
+ imports = [ <modules/workstation/ui/kitty/default.nix> ];
+
+ # Customise kitty installation
+ libkookie.ui.kitty = {
+ enable = true;
+ fontSize = 11;
+ };
+}