aboutsummaryrefslogtreecommitdiff
path: root/infra/corenix/configs/kookie/uwu.nix
diff options
context:
space:
mode:
Diffstat (limited to 'infra/corenix/configs/kookie/uwu.nix')
-rw-r--r--infra/corenix/configs/kookie/uwu.nix17
1 files changed, 15 insertions, 2 deletions
diff --git a/infra/corenix/configs/kookie/uwu.nix b/infra/corenix/configs/kookie/uwu.nix
index 3dc56baf8faf..7456c6dc3c94 100644
--- a/infra/corenix/configs/kookie/uwu.nix
+++ b/infra/corenix/configs/kookie/uwu.nix
@@ -3,7 +3,21 @@
{
imports = [ ../boards/x230.nix ../common.nix ];
- seabios.enable = true;
+ grub2 = {
+ enable = true;
+ extraPayloadModules = [ "luks" "crypto" "gcry_sha256"
+ "gcry_rijndael" "pbkdf2" ];
+ extraConfig = ''
+ menuentry "NixOS" {
+ cryptomount -u f1440abd-99e3-46a8-aa36-7824972fee54
+ search --set=drive1 --fs-uuid 672c497c-18aa-4b00-ac95-78e810363d81
+ set root=$drive1
+ configfile /grub/grub.cfg
+ }
+ '';
+ };
+
+ seabios.asSecondaryPayload = true;
corenix = {
corebootConfig = {
@@ -12,6 +26,5 @@
};
extraFiles."background.png".src = lib.mkForce ./splash.jpg;
-
};
}