aboutsummaryrefslogtreecommitdiff
path: root/infra/corenix/configs/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'infra/corenix/configs/common.nix')
-rw-r--r--infra/corenix/configs/common.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/infra/corenix/configs/common.nix b/infra/corenix/configs/common.nix
new file mode 100644
index 000000000000..1e091cc29cd4
--- /dev/null
+++ b/infra/corenix/configs/common.nix
@@ -0,0 +1,11 @@
+{ lib, ... }:
+
+{
+ corenix.corebootConfig = {
+ CONFIG_PAYLOAD_NONE = "y"; # payload is added later
+ CONFIG_CBFS_SIZE = lib.mkDefault "0x300000";
+ CONFIG_USE_OPTION_TABLE = lib.mkDefault "y";
+ CONFIG_PCIEXP_CLK_PM = lib.mkDefault "y";
+ CONFIG_GENERIC_LINEAR_FRAMEBUFFER = lib.mkDefault "y";
+ };
+}