aboutsummaryrefslogtreecommitdiff
path: root/games/rstnode/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'games/rstnode/shell.nix')
-rw-r--r--games/rstnode/shell.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/games/rstnode/shell.nix b/games/rstnode/shell.nix
index 207d5ef3cd33..e26d8c53c107 100644
--- a/games/rstnode/shell.nix
+++ b/games/rstnode/shell.nix
@@ -4,8 +4,17 @@ mkShell rec {
name = "rstnode-shell";
buildInputs = with pkgs; [
rustc cargo clangStdenv rust-analyzer rustfmt
- alsaLib pkg-config libudev
+
+ # ggez dependencies
+ pkg-config alsaLib libudev
+
+ # librsvg dependencies
+ glib cairo pango gdk-pixbuf libxml2
+
+
] ++ (with pkgs.xlibs; [
+ # General opengl dependencies
+
libGL
libGLU
libGL_driver