aboutsummaryrefslogtreecommitdiff
path: root/games/rstnode/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'games/rstnode/Cargo.toml')
-rw-r--r--games/rstnode/Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/games/rstnode/Cargo.toml b/games/rstnode/Cargo.toml
new file mode 100644
index 000000000000..c62fd1354e38
--- /dev/null
+++ b/games/rstnode/Cargo.toml
@@ -0,0 +1,26 @@
+[package]
+name = "rstnode"
+description = "A game about capturing computers on a network"
+version = "0.0.0"
+edition = "2018"
+license = "AGPL-3.0-or-later"
+authors = ["Bread Machine", "Katharina Fey <kookie@spacekookie.de>"]
+
+[dependencies]
+serde = { version = "1.0", features = ["derive", "rc"] }
+serde_json = "1.0"
+async-std = { version = "1.0", features = ["unstable"] }
+async-trait = "0.1"
+
+ratman = "0.1.0"
+netmod-mem = "0.1.0"
+identity = { version = "0.4", features = ["random"], package = "ratman-identity"}
+
+ggez = "0.5"
+cgmath = { version = "*", features = ["mint"] }
+chrono = { version = "0.4", features = ["serde"] }
+rand = "0.7"
+quadtree_rs = "0.1"
+
+# [profile.release.overrides."*"]
+# opt-level = 3 \ No newline at end of file