aboutsummaryrefslogtreecommitdiff
path: root/development/tools/cargo-workspace2/tests/resources/lockchain-http/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'development/tools/cargo-workspace2/tests/resources/lockchain-http/Cargo.toml')
-rw-r--r--development/tools/cargo-workspace2/tests/resources/lockchain-http/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/development/tools/cargo-workspace2/tests/resources/lockchain-http/Cargo.toml b/development/tools/cargo-workspace2/tests/resources/lockchain-http/Cargo.toml
new file mode 100644
index 000000000000..91500336aafe
--- /dev/null
+++ b/development/tools/cargo-workspace2/tests/resources/lockchain-http/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "lockchain-http"
+description = "Generic HTTP interface crate for the lockchain ecosystem. Can serve both encrypted and cleartext records"
+version = "0.4.1-alpha.0"
+authors = ["Katharina Fey <kookie@spacekookie.de>"]
+
+documentation = "https://docs.rs/lockchain-http"
+homepage = "https://github.com/spacekookie/lockchain/tree/master/lockchain-http"
+readme = "README.md"
+license = "MIT/X11 OR Apache-2.0"
+
+[dependencies]
+lockchain-core = { version = "0.9.1-alpha.0", path = "../lockchain-core" }
+env_logger = "0.5"
+
+# Serialisation stack
+serde = "1.0"
+serde_derive = "1.0"
+
+# Web Stack
+futures = "0.1"
+actix = "0.5"
+actix-web = "0.6" \ No newline at end of file