aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2020-01-29 06:49:50 +0000
committerKatharina Fey <kookie@spacekookie.de>2020-01-29 06:49:50 +0000
commitb38baf21dbe44bbbe464a97529a2e27424339119 (patch)
treeb8e57f7cc32a17583952357cd27d5633c6a0966b /shell.nix
Adding project outline and structure filse
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 000000000000..232c8003324c
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,13 @@
+with import <nixpkgs> {};
+
+stdenv.mkDerivation {
+ name = "qaul";
+ buildInputs = with pkgs; [
+ rustracer rustup clangStdenv
+
+ cargo-watch
+
+ # Required for the docs
+ mdbook graphviz
+ ];
+}