aboutsummaryrefslogtreecommitdiff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorSandro Jäckel <sandro.jaeckel@gmail.com>2020-12-03 11:15:10 +0100
committerSandro Jäckel <sandro.jaeckel@gmail.com>2020-12-03 11:15:10 +0100
commitde499540aeb5d5e9371d5722c6abaa1c3b88530d (patch)
tree0644c07649ee35c43511f11c9bdc344f0a150a1d /pkgs/tools
parentc0a87f4f5856ad4862fa317d474e912010eef298 (diff)
nix-update-source: switch to pname, version
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/package-management/nix-update-source/default.nix12
1 files changed, 8 insertions, 4 deletions
diff --git a/pkgs/tools/package-management/nix-update-source/default.nix b/pkgs/tools/package-management/nix-update-source/default.nix
index a2add8f8a78e..9b7326db0343 100644
--- a/pkgs/tools/package-management/nix-update-source/default.nix
+++ b/pkgs/tools/package-management/nix-update-source/default.nix
@@ -1,14 +1,16 @@
-{ lib, pkgs, fetchFromGitHub, python3Packages, nix-prefetch-scripts
-, runtimeShell }:
+{ lib, pkgs, fetchFromGitHub, python3Packages, nix-prefetch-scripts, runtimeShell }:
+
python3Packages.buildPythonApplication rec {
+ pname = "nix-update-source";
version = "0.6.3";
- name = "nix-update-source-${version}";
+
src = fetchFromGitHub {
owner = "timbertson";
repo = "nix-update-source";
- rev = "version-0.6.3";
+ rev = "version-${version}";
sha256 = "157wvv9vnaszzwbj68jpdc0imcm1hdab3z760bx2axbsgfpqqilz";
};
+
propagatedBuildInputs = [ nix-prefetch-scripts ];
passthru = {
# NOTE: `fetch` should not be used within nixpkgs because it
@@ -28,6 +30,7 @@ python3Packages.buildPythonApplication rec {
inherit src;
overrideSrc = drv: lib.overrideDerivation drv (orig: { inherit src; });
};
+
updateScript = ''
#!${runtimeShell}
set -e
@@ -43,6 +46,7 @@ python3Packages.buildPythonApplication rec {
--modify-nix default.nix
'';
};
+
meta = {
description = "Utility to automate updating of nix derivation sources";
maintainers = with lib.maintainers; [ timbertson ];