aboutsummaryrefslogtreecommitdiff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2020-12-04 18:14:51 +0000
committerGitHub <noreply@github.com>2020-12-04 18:14:51 +0000
commitcb36dd7449c2cd8ed0d9c9946a3ffe0460a742b1 (patch)
treeabe3563a0bfd150dd72db39d0b1def08b359c74e /pkgs/tools
parent5524c43f2c0cc246de33d6eff378dcad843b2617 (diff)
parentb66ea6fc39acc588ecc8ccb1409995f2444862df (diff)
Merge master into staging-next
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/graphics/gromit-mpx/default.nix4
-rw-r--r--pkgs/tools/inputmethods/ibus-engines/ibus-mozc/default.nix37
-rw-r--r--pkgs/tools/misc/fluent-bit/default.nix4
-rw-r--r--pkgs/tools/misc/goreleaser/default.nix4
-rw-r--r--pkgs/tools/networking/gping/default.nix6
-rw-r--r--pkgs/tools/security/pass/default.nix6
-rw-r--r--pkgs/tools/security/pass/extensions/audit/default.nix3
7 files changed, 29 insertions, 35 deletions
diff --git a/pkgs/tools/graphics/gromit-mpx/default.nix b/pkgs/tools/graphics/gromit-mpx/default.nix
index c7f0beba8fb8..b8c344258bb9 100644
--- a/pkgs/tools/graphics/gromit-mpx/default.nix
+++ b/pkgs/tools/graphics/gromit-mpx/default.nix
@@ -6,13 +6,13 @@
stdenv.mkDerivation rec {
pname = "gromit-mpx";
- version = "1.3.1";
+ version = "1.4";
src = fetchFromGitHub {
owner = "bk138";
repo = "gromit-mpx";
rev = version;
- sha256 = "1dvn7vwg4fg1a3lfj5f7nij1vcxm27gyf2wr817f3qb4sx5xmjwy";
+ sha256 = "1xn14r7lhay720y78j1fs4amp5lia39kpq7vzv02x4nnwhgbsd9r";
};
nativeBuildInputs = [ pkgconfig wrapGAppsHook ];
diff --git a/pkgs/tools/inputmethods/ibus-engines/ibus-mozc/default.nix b/pkgs/tools/inputmethods/ibus-engines/ibus-mozc/default.nix
index 41a04d018355..695a45d81ffc 100644
--- a/pkgs/tools/inputmethods/ibus-engines/ibus-mozc/default.nix
+++ b/pkgs/tools/inputmethods/ibus-engines/ibus-mozc/default.nix
@@ -1,5 +1,5 @@
-{ clangStdenv, fetchFromGitHub, fetchpatch, which, ninja, python, gyp, pkgconfig
-, protobuf, ibus, gtk2, zinnia, qt5, libxcb, tegaki-zinnia-japanese }:
+{ stdenv, fetchFromGitHub, which, ninja, python, pkgconfig, protobuf
+, ibus, gtk2, zinnia, qt5, libxcb, tegaki-zinnia-japanese, python3Packages }:
let
japanese_usage_dictionary = fetchFromGitHub {
@@ -8,11 +8,11 @@ let
rev = "e5b3425575734c323e1d947009dd74709437b684";
sha256 = "0pyrpz9c8nxccwpgyr36w314mi8h132cis8ijvlqmmhqxwsi30hm";
};
-in clangStdenv.mkDerivation rec {
+in stdenv.mkDerivation rec {
name = "ibus-mozc-${version}";
- version = "2.23.2815.102";
+ version = "2.23.4206.102";
- meta = with clangStdenv.lib; {
+ meta = with stdenv.lib; {
isIbusEngine = true;
description = "Japanese input method from Google";
homepage = "https://github.com/google/mozc";
@@ -21,37 +21,28 @@ in clangStdenv.mkDerivation rec {
maintainers = with maintainers; [ gebner ericsagnes ];
};
- nativeBuildInputs = [ which ninja python gyp pkgconfig qt5.wrapQtAppsHook ];
+ nativeBuildInputs = [ which ninja python3Packages.python python3Packages.six
+ python3Packages.gyp pkgconfig qt5.wrapQtAppsHook ];
buildInputs = [ protobuf ibus gtk2 zinnia qt5.qtbase libxcb ];
src = fetchFromGitHub {
owner = "google";
repo = "mozc";
- rev = "afb03ddfe72dde4cf2409863a3bfea160f7a66d8";
- sha256 = "0w2dy2j9x5nc7x3g95j17r3m60vbfyn5j617h7js9xryv33yzpgx";
+ rev = "91cc1e19ef34aeb12888b697fefa52907f1a834d";
+ sha256 = "1fyy9g1pnaq6s5nkf56aqmp5mgyibbmp1ylc64fqc6g1plg90zk2";
+ fetchSubmodules = true;
};
- patches = [
- # https://github.com/google/mozc/pull/444 - fix for gcc8 STL
- (fetchpatch {
- url = "https://github.com/google/mozc/commit/82d38f929882a9c62289b179c6fe41efed249987.patch";
- sha256 = "07cja1b7qfsd3i76nscf1zwiav74h7d6h2g9g2w4bs3h1mc9jwla";
- })
- # Support dates after 2019
- (fetchpatch {
- url = "https://salsa.debian.org/debian/mozc/-/raw/master/debian/patches/add_support_new_japanese_era.patch";
- sha256 = "1dsiiglrmm8i8shn2hv0j2b8pv6miysjrimj4569h606j4lwmcw2";
- })
- ];
-
postUnpack = ''
- rmdir $sourceRoot/src/third_party/japanese_usage_dictionary/
+ rm -rf $sourceRoot/src/third_party/japanese_usage_dictionary/
ln -s ${japanese_usage_dictionary} $sourceRoot/src/third_party/japanese_usage_dictionary
+ '' + stdenv.lib.optionalString stdenv.isLinux ''
+ sed -i 's/-lc++/-lstdc++/g' $sourceRoot/src/gyp/common.gypi
'';
configurePhase = ''
export GYP_DEFINES="document_dir=$out/share/doc/mozc use_libzinnia=1 use_libprotobuf=1 ibus_mozc_path=$out/lib/ibus-mozc/ibus-engine-mozc zinnia_model_file=${tegaki-zinnia-japanese}/share/tegaki/models/zinnia/handwriting-ja.model"
- cd src && python build_mozc.py gyp --gypdir=${gyp}/bin --server_dir=$out/lib/mozc
+ cd src && python build_mozc.py gyp --gypdir=${python3Packages.gyp}/bin --server_dir=$out/lib/mozc
'';
buildPhase = ''
diff --git a/pkgs/tools/misc/fluent-bit/default.nix b/pkgs/tools/misc/fluent-bit/default.nix
index 2f736a63d977..ec1a0072a559 100644
--- a/pkgs/tools/misc/fluent-bit/default.nix
+++ b/pkgs/tools/misc/fluent-bit/default.nix
@@ -2,13 +2,13 @@
stdenv.mkDerivation rec {
pname = "fluent-bit";
- version = "1.6.6";
+ version = "1.6.7";
src = fetchFromGitHub {
owner = "fluent";
repo = "fluent-bit";
rev = "v${version}";
- sha256 = "0hkl0wb1xsq7z7gbmblq4fj42llw58lxgvm41z7bliq8a2qg3hv9";
+ sha256 = "1rybz69yhjm1g8m6wmn6v143a65y69w2fvs62yr8n1r92cadzbia";
};
nativeBuildInputs = [ cmake flex bison ];
diff --git a/pkgs/tools/misc/goreleaser/default.nix b/pkgs/tools/misc/goreleaser/default.nix
index 31e925af6ce2..58a7ce619c5a 100644
--- a/pkgs/tools/misc/goreleaser/default.nix
+++ b/pkgs/tools/misc/goreleaser/default.nix
@@ -2,13 +2,13 @@
buildGoModule rec {
pname = "goreleaser";
- version = "0.148.0";
+ version = "0.149.0";
src = fetchFromGitHub {
owner = "goreleaser";
repo = pname;
rev = "v${version}";
- sha256 = "11dzh5scfwf8lm0rw5f3z0plix5p4mmvgigzav2g59p0wdw3v3jy";
+ sha256 = "14yvxnl2ap1hizpk3pfzlh36399df1z2zgsc63qdh1h4ixyav6cy";
};
vendorSha256 = "17l15z2wyxzh7h7hvb1fysdnyg8wr8ww827vvmki73s1plfgr80d";
diff --git a/pkgs/tools/networking/gping/default.nix b/pkgs/tools/networking/gping/default.nix
index ece9c47ae684..fdf5c9ad704b 100644
--- a/pkgs/tools/networking/gping/default.nix
+++ b/pkgs/tools/networking/gping/default.nix
@@ -5,16 +5,16 @@
rustPlatform.buildRustPackage rec {
pname = "gping";
- version = "1.0.1-post2";
+ version = "1.1.0";
src = fetchFromGitHub {
owner = "orf";
repo = "gping";
rev = "v${version}";
- sha256 = "0cvbwxvq1cj9xcjc3hnxrpq9yrmfkapy533cbjzsjmvgiqk11hps";
+ sha256 = "10hvzgn98qbzs7mmql9wlbll814mkki29lvg71lbvr81wlbdn6mr";
};
- cargoSha256 = "0vdhincvfassj7gbiplwbi43yyic3l6wlc32s6ci68b2wjmff8pn";
+ cargoSha256 = "0kkfrdzyy5068k8nz08pfc4cl1dvn0vd6i01gax5dblk122ybbag";
meta = with lib; {
description = "Ping, but with a graph";
diff --git a/pkgs/tools/security/pass/default.nix b/pkgs/tools/security/pass/default.nix
index 9ba03fc74a2f..9e9348105010 100644
--- a/pkgs/tools/security/pass/default.nix
+++ b/pkgs/tools/security/pass/default.nix
@@ -1,6 +1,6 @@
{ stdenv, lib, pkgs, fetchurl, buildEnv
-, coreutils, gnused, getopt, git, tree, gnupg, openssl, which, procps
-, qrencode , makeWrapper, pass, symlinkJoin
+, coreutils, findutils, gnugrep, gnused, getopt, git, tree, gnupg, openssl
+, which, procps , qrencode , makeWrapper, pass, symlinkJoin
, xclip ? null, xdotool ? null, dmenu ? null
, x11Support ? !stdenv.isDarwin , dmenuSupport ? x11Support
@@ -80,8 +80,10 @@ stdenv.mkDerivation rec {
wrapperPath = with stdenv.lib; makeBinPath ([
coreutils
+ findutils
getopt
git
+ gnugrep
gnupg
gnused
tree
diff --git a/pkgs/tools/security/pass/extensions/audit/default.nix b/pkgs/tools/security/pass/extensions/audit/default.nix
index 144d13238f26..ec0f23ddc383 100644
--- a/pkgs/tools/security/pass/extensions/audit/default.nix
+++ b/pkgs/tools/security/pass/extensions/audit/default.nix
@@ -30,7 +30,8 @@ in stdenv.mkDerivation rec {
buildInputs = [ pythonEnv ];
nativeBuildInputs = [ makeWrapper ];
- doCheck = true;
+ # Tests freeze on darwin with: pass-audit-1.1 (checkPhase): EOFError
+ doCheck = !stdenv.isDarwin;
checkInputs = [ pythonPackages.green pass gnupg ];
checkPhase = ''
${pythonEnv}/bin/python3 setup.py green -q