aboutsummaryrefslogtreecommitdiff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJosh Holland <josh@inv.alid.pw>2020-07-28 12:54:30 +0100
committerJosh Holland <josh@inv.alid.pw>2020-11-07 11:20:20 +0000
commitbcb92f53d59bb9f63fbe537ac17b9780852a339b (patch)
tree4f4993fac16eae2f5ff2409af0c009ba11d8cc1c /pkgs/tools
parent4c68a713372a6a021e4e3f4f16565be1605f10d0 (diff)
as-tree: init at 0.12.0
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/as-tree/cargo-lock.patch13
-rw-r--r--pkgs/tools/misc/as-tree/default.nix27
2 files changed, 40 insertions, 0 deletions
diff --git a/pkgs/tools/misc/as-tree/cargo-lock.patch b/pkgs/tools/misc/as-tree/cargo-lock.patch
new file mode 100644
index 000000000000..f7a06c050d2d
--- /dev/null
+++ b/pkgs/tools/misc/as-tree/cargo-lock.patch
@@ -0,0 +1,13 @@
+diff --git a/Cargo.lock b/Cargo.lock
+index 991ecd8..9e94574 100644
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -11,7 +11,7 @@ dependencies = [
+
+ [[package]]
+ name = "as-tree"
+-version = "0.11.1"
++version = "0.12.0"
+ dependencies = [
+ "ansi_term",
+ "atty",
diff --git a/pkgs/tools/misc/as-tree/default.nix b/pkgs/tools/misc/as-tree/default.nix
new file mode 100644
index 000000000000..7cc97fd79e46
--- /dev/null
+++ b/pkgs/tools/misc/as-tree/default.nix
@@ -0,0 +1,27 @@
+{ lib, fetchFromGitHub, rustPlatform }:
+
+rustPlatform.buildRustPackage rec {
+ pname = "as-tree";
+ version = "0.12.0";
+
+ src = fetchFromGitHub {
+ owner = "jez";
+ repo = pname;
+ rev = version;
+ sha256 = "0c0g32pkyhyvqpgvzlw9244c80npq6s8mxy3may7q4qyd7hi3dz5";
+ };
+
+ cargoSha256 = "0yhd9svdxg7akv61msn7rf3rfblb7kxnyn955dfdwyxbxq48qwpr";
+ # the upstream 0.12.0 release didn't update the Cargo.lock file properly
+ # they have updated their release script, so this patch can be removed
+ # when the next version is released.
+ cargoPatches = [ ./cargo-lock.patch ];
+
+ meta = with lib; {
+ description = "Print a list of paths as a tree of paths";
+ homepage = "https://github.com/jez/as-tree";
+ license = with licenses; [ blueOak100 ];
+ maintainers = with maintainers; [ jshholland ];
+ platforms = platforms.all;
+ };
+}