aboutsummaryrefslogtreecommitdiff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorSandro <sandro.jaeckel@gmail.com>2020-12-03 01:06:56 +0100
committerGitHub <noreply@github.com>2020-12-03 01:06:56 +0100
commit535c1daca6705026c6858a5aca1229064ed537d0 (patch)
tree2f906aba8f3d567b11c03f0a982542a120968bbe /pkgs/tools
parent7a34bcc2a32493b204192cabb898f025cd4ba008 (diff)
parent20eb5c38e1e823c07e7c14985b9075f0f1e38904 (diff)
Merge pull request #105713 from fgaz/use-unstable-updater
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/cht.sh/default.nix4
-rw-r--r--pkgs/tools/security/bash-supergenpass/default.nix15
2 files changed, 14 insertions, 5 deletions
diff --git a/pkgs/tools/misc/cht.sh/default.nix b/pkgs/tools/misc/cht.sh/default.nix
index 1c38e7c3b8f5..ceef26b577d6 100644
--- a/pkgs/tools/misc/cht.sh/default.nix
+++ b/pkgs/tools/misc/cht.sh/default.nix
@@ -1,5 +1,6 @@
{ stdenv
, fetchFromGitHub
+, unstableGitUpdater
, makeWrapper
, curl
, ncurses
@@ -35,6 +36,8 @@ stdenv.mkDerivation {
--prefix PATH : "${stdenv.lib.makeBinPath [ curl rlwrap ncurses xsel ]}"
'';
+ passthru.updateScript = unstableGitUpdater { };
+
meta = with stdenv.lib; {
description = "CLI client for cheat.sh, a community driven cheat sheet";
license = licenses.mit;
@@ -42,4 +45,3 @@ stdenv.mkDerivation {
homepage = "https://github.com/chubin/cheat.sh";
};
}
-
diff --git a/pkgs/tools/security/bash-supergenpass/default.nix b/pkgs/tools/security/bash-supergenpass/default.nix
index f72c916acf99..53bc45acf8f7 100644
--- a/pkgs/tools/security/bash-supergenpass/default.nix
+++ b/pkgs/tools/security/bash-supergenpass/default.nix
@@ -1,8 +1,14 @@
-{ stdenv, fetchFromGitHub, makeWrapper, openssl, coreutils, gnugrep }:
+{ stdenv
+, fetchFromGitHub
+, unstableGitUpdater
+, makeWrapper
+, openssl
+, coreutils
+, gnugrep }:
stdenv.mkDerivation {
- pname = "bash-supergenpass-unstable";
- version = "2018-04-18";
+ pname = "bash-supergenpass";
+ version = "unstable-2018-04-18";
nativeBuildInputs = [ makeWrapper ];
@@ -18,6 +24,8 @@ stdenv.mkDerivation {
wrapProgram "$out/bin/supergenpass" --prefix PATH : "${stdenv.lib.makeBinPath [ openssl coreutils gnugrep ]}"
'';
+ passthru.updateScript = unstableGitUpdater { };
+
meta = with stdenv.lib; {
description = "Bash shell-script implementation of SuperGenPass password generation";
longDescription = ''
@@ -36,4 +44,3 @@ stdenv.mkDerivation {
homepage = "https://github.com/lanzz/bash-supergenpass";
};
}
-