aboutsummaryrefslogtreecommitdiff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorMarin <supermarin@users.noreply.github.com>2020-12-06 18:26:39 +0300
committerGitHub <noreply@github.com>2020-12-06 10:26:39 -0500
commit3d629ef7231b9e477d7fafd2705675cfd5f37b8b (patch)
tree34d2ce9c5e82dade2f9384f05278a319531da500 /pkgs/tools
parent6c94fd93bc12a578e499b9a5bf1880ac9cf5f75c (diff)
rage: fix macOS build (#106051)
Without the explicit Foundation dep, linker fails with this message: ``` = note: ld: framework not found Foundation clang-7: error: linker command failed with exit code 1 (use -v to see invocation) error: aborting due to previous error error: could not compile `i18n-embed-fl` ``` Co-authored-by: Dmitry Kalinkin <dmitry.kalinkin@gmail.com>
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/rage/default.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/pkgs/tools/security/rage/default.nix b/pkgs/tools/security/rage/default.nix
index 1e0164e10cf4..69ea8c0f9c2c 100644
--- a/pkgs/tools/security/rage/default.nix
+++ b/pkgs/tools/security/rage/default.nix
@@ -1,4 +1,5 @@
-{ stdenv, rustPlatform, fetchFromGitHub, installShellFiles, darwin }:
+{ stdenv, rustPlatform, fetchFromGitHub, installShellFiles
+, Foundation, Security }:
rustPlatform.buildRustPackage rec {
pname = "rage";
@@ -15,7 +16,10 @@ rustPlatform.buildRustPackage rec {
nativeBuildInputs = [ installShellFiles ];
- buildInputs = stdenv.lib.optionals stdenv.isDarwin [ darwin.apple_sdk.frameworks.Security ];
+ buildInputs = stdenv.lib.optionals stdenv.isDarwin [
+ Foundation
+ Security
+ ];
postBuild = ''
cargo run --example generate-docs