aboutsummaryrefslogtreecommitdiff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorVladimír Čunát <v@cunat.cz>2020-06-10 16:13:48 +0200
committerVladimír Čunát <v@cunat.cz>2020-06-10 16:13:48 +0200
commita5f5d020c69c22ddc6be48123ef4d30fd262c403 (patch)
treebfb79b323b549e1f10a94d0153fdd3761ae893a6 /pkgs/stdenv
parented43d951af1030d01e22fe0aaaed568af4e7e8e9 (diff)
parentbbe71613b6e656e707acdf9c279736c900bf4e87 (diff)
Merge branch 'staging-next'
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/darwin/default.nix13
-rw-r--r--pkgs/stdenv/generic/default.nix4
-rw-r--r--pkgs/stdenv/generic/make-derivation.nix10
3 files changed, 9 insertions, 18 deletions
diff --git a/pkgs/stdenv/darwin/default.nix b/pkgs/stdenv/darwin/default.nix
index ef1ebfc32c1b..b69de041fd23 100644
--- a/pkgs/stdenv/darwin/default.nix
+++ b/pkgs/stdenv/darwin/default.nix
@@ -36,9 +36,7 @@ in rec {
export NIX_IGNORE_LD_THROUGH_GCC=1
export SDKROOT=
- # Ensure consistent LC_VERSION_MIN_MACOSX and remove LC_UUID.
export MACOSX_DEPLOYMENT_TARGET=${macosVersionMin}
- export NIX_LDFLAGS+=" -macosx_version_min ${macosVersionMin} -sdk_version ${appleSdkVersion} -no_uuid"
# Workaround for https://openradar.appspot.com/22671534 on 10.11.
export gl_cv_func_getcwd_abort_bug=no
@@ -307,7 +305,7 @@ in rec {
inherit
gnumake gzip gnused bzip2 gawk ed xz patch bash python3
ncurses libffi zlib gmp pcre gnugrep
- coreutils findutils diffutils patchutils ninja;
+ coreutils findutils diffutils patchutils ninja libxml2;
# Hack to make sure we don't link ncurses in bootstrap tools. The proper
# solution is to avoid passing -L/nix-store/...-bootstrap-tools/lib,
@@ -321,7 +319,7 @@ in rec {
llvmPackages_7 = super.llvmPackages_7 // (let
tools = super.llvmPackages_7.tools.extend (llvmSelf: _: {
clang-unwrapped = llvmPackages_7.clang-unwrapped.override { llvm = llvmSelf.llvm; };
- llvm = llvmPackages_7.llvm.override { libxml2 = self.darwin.libxml2-nopython; };
+ llvm = llvmPackages_7.llvm.override { inherit libxml2; };
});
libraries = super.llvmPackages_7.libraries.extend (llvmSelf: _: {
inherit (llvmPackages_7) libcxx libcxxabi compiler-rt;
@@ -332,9 +330,8 @@ in rec {
inherit (darwin) dyld Libsystem libiconv locale;
cctools = super.darwin.cctools.override { enableTapiSupport = false; };
- libxml2-nopython = super.libxml2.override { pythonSupport = false; };
CF = super.darwin.CF.override {
- libxml2 = libxml2-nopython;
+ inherit libxml2;
python3 = prevStage.python3;
};
};
@@ -419,9 +416,9 @@ in rec {
gnugrep llvmPackages.clang-unwrapped llvmPackages.clang-unwrapped.lib patch pcre.out gettext
binutils.bintools darwin.binutils darwin.binutils.bintools
curl.out openssl.out libssh2.out nghttp2.lib libkrb5
- cc.expand-response-params
+ cc.expand-response-params libxml2.out
]) ++ (with pkgs.darwin; [
- dyld Libsystem CF cctools ICU libiconv locale libxml2-nopython.out
+ dyld Libsystem CF cctools ICU libiconv locale
]);
overrides = lib.composeExtensions persistent (self: super: {
diff --git a/pkgs/stdenv/generic/default.nix b/pkgs/stdenv/generic/default.nix
index 77d70e84258d..e17b41eab320 100644
--- a/pkgs/stdenv/generic/default.nix
+++ b/pkgs/stdenv/generic/default.nix
@@ -98,7 +98,7 @@ let
# TODO: This really wants to be in stdenv/darwin but we don't have hostPlatform
# there (yet?) so it goes here until then.
preHook = preHook+ lib.optionalString buildPlatform.isDarwin ''
- export NIX_BUILD_DONT_SET_RPATH=1
+ export NIX_DONT_SET_RPATH_FOR_BUILD=1
'' + lib.optionalString (hostPlatform.isDarwin || (hostPlatform.parsed.kernel.execFormat != lib.systems.parse.execFormats.elf && hostPlatform.parsed.kernel.execFormat != lib.systems.parse.execFormats.macho)) ''
export NIX_DONT_SET_RPATH=1
export NIX_NO_SELF_RPATH=1
@@ -107,7 +107,7 @@ let
# think the best solution would just be to fixup linux RPATHs so we don't
# need to set `-rpath` anywhere.
# + lib.optionalString targetPlatform.isDarwin ''
- # export NIX_TARGET_DONT_SET_RPATH=1
+ # export NIX_DONT_SET_RPATH_FOR_TARGET=1
# ''
;
diff --git a/pkgs/stdenv/generic/make-derivation.nix b/pkgs/stdenv/generic/make-derivation.nix
index 09879451d8e4..993ae68e9e81 100644
--- a/pkgs/stdenv/generic/make-derivation.nix
+++ b/pkgs/stdenv/generic/make-derivation.nix
@@ -262,7 +262,7 @@ in rec {
else if isx86_32 then "x86"
else if isx86_64 then "x86_64"
else platform.parsed.cpu.family + builtins.toString platform.parsed.cpu.bits;
- crossFile = builtins.toFile "cross-file.conf" (''
+ crossFile = builtins.toFile "cross-file.conf" ''
[properties]
needs_exe_wrapper = true
@@ -271,13 +271,7 @@ in rec {
cpu_family = '${cpuFamily stdenv.targetPlatform}'
cpu = '${stdenv.targetPlatform.parsed.cpu.name}'
endian = ${if stdenv.targetPlatform.isLittleEndian then "'little'" else "'big'"}
- ''
- # TODO should have target prefix too, issue #86077
- + ''
-
- [binaries]
- pkgconfig = 'pkg-config'
- '');
+ '';
in [ "--cross-file=${crossFile}" ] ++ mesonFlags;
} // lib.optionalAttrs (attrs.enableParallelBuilding or false) {
enableParallelChecking = attrs.enableParallelChecking or true;